7

I have installed Civilization 5 from Steam and it was working fine, but when I tried to run it this morning it got stuck at the first step with the message Preparing to launch Sid Meier's Civilization V. What should I do?

4
  • 3
    Restart Steam and try again. Commented Apr 18, 2015 at 11:42
  • I did and it is still the same. I have tried to launch anther game and it ran with no problems. After that, I tried to launch Civ 5 again and it still does the same thing. Commented Apr 18, 2015 at 11:48
  • Did you try verifying the game cache? Commented Apr 18, 2015 at 12:19
  • 3
    To verify the game cache right click on the steam game and go to properties > Local files > Verify Integrity
    – DanceSC
    Commented Apr 20, 2015 at 22:49

1 Answer 1

1

Try opening Task Manager and see if Civ's service (Launcher.exe) is already running in the background.

When I get this error with games, usually the above is the cause of the problem, and killing the process and starting the game again from Steam solves it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .