4

I thought just for fun I'd enter in some commands, but ever since I haven't been able to remove the console.

I tried Ctrl + L, ~, disabling it. Nothing.

I can remove it with Ctrl + L for a brief time until I click with my mouse then it brings it up again.

I even exited my world and shut the game down and it's still doing this. It's kind of annoying and prevents me from being able to play the game.

  • dont-starve-game.wikia.com/wiki/Console maybe disable it in settings.ini? I don't have the game so I can't confirm. – Elias Benevedes Apr 23 '15 at 1:42
  • I disabled it. Still there somehow. – OneWithTheSkies Apr 23 '15 at 1:44
  • 1
    There a world file? You could copy it over, reinstall, drop back in. – Elias Benevedes Apr 23 '15 at 1:45
  • I don't know, but it's happening on all worlds. Old ones and newly created ones. – OneWithTheSkies Apr 23 '15 at 1:48
  • It's worth disabling all your mods to check if mods are the issue. – rlb.usa Jun 17 '15 at 15:45
1

Check the settings in your Documents/Klei folder, and make sure that ENABLECONSOLE is false:

[MISC]
ENABLECONSOLE = false
...

Next, check that all your files are intact. It could be that somehow your scripts/constants.lua got damaged. Make sure that the values of the following three constants are still valid:

CONTROL_OPEN_DEBUG_CONSOLE = 42
CONTROL_TOGGLE_LOG = 43
CONTROL_TOGGLE_DEBUGRENDER = 44

Last, but not least, make sure that it's not a configuration problem. Go into your settings menu, then controls, and click on the right arrow till you get to the last page. Make sure that the debug/console/log functionalities aren't bound to wrong keys or even a mouse button.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.