0

I have a PS3 controller for playing games on my Android phone, but it doesn't seem to want to charge. I've spent two days looking up reasons why and tried them (those attempts listed below) but nothing worked, so I figured it was just dead.

So I went to the store and I bought another one, brand new (official Sony and everything) and it's acting exactly the same. Literally every single thing the old one does, the new one responds identically, leading me to believe I'm simply not doing something right.

I have tried plugging the controllers into the following configurations:

  • Wall USB: 5V 1000MaH, no signs of affect
  • Another wall USB: 5V 1000MaH, no signs of affect
  • Laptop (plugged in) USB2: All four lights flash ~3 times, and the computer recognizes it as a PS3 controller, but then the lights turn off and the only way to get them on again is unplug-replug (or press/release the controller's reset button)
  • Laptop (plugged in) USB3: Exactly the same as USB2

I have tried resetting the controllers, I have tried pressing the PS logo for 10 seconds, I have tried both at the same time. No lights, no signs of anything. Literally the only way any light blinks at all is if it's plugged into the computer, and then only all lights for ~3 flashes, then nothing.

Also: I have used two miniUSB cables for this, one that came with my TomTom and one that came with my GoPro. Just like using different controllers, different wall USB charger or different USB ports on my laptop, the cables made zero difference.

Does anyone have any idea how to charge one of these things? I don't have a PS3, and I used to be able to charge the old PS3 controller, but either it stopped working that way or (more likely) I did something back then which I have since forgotten about which was critically important.

  • Most wall adapters won't work because of the reason given here: gaming.stackexchange.com/a/74015 Your laptop should work, but make sure the it's open and is not sleeping or anything otherwise the USB ports might not be fully powered. – user86571 Apr 24 '15 at 0:20
  • I saw that post, but I swore it was working with one before. Regardless, I've had it in the laptop (while working on it) for 5 hours and still nothing. – Bing Apr 24 '15 at 1:29
  • There's nothing more than that you need to do then. I charge my PS3 controller using my PC's USB ports all the time. Might be something wrong with your cables. You might also want to double check nothing happens with your controllers when you push (just push, not hold) the PS button. Disconnect the USB cable before doing so. If there's any charge in them at all the four LEDs will blink quickly, a few times a second, and keep blinking until they find the PS3 (or other device) that they're paired with. – user86571 Apr 24 '15 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.