0

I've searched for a solution to this problem for days, all together. I can't seem to get it fixed.

Since AC4:Black Flag the game is saying the Ubisoft Server are offline. Every time. It's a little annoying in Black Flag because I can't play Kenways's fleet. But now I have Rogue and it tells me the exact same thing.

So far I've tried: - Resetting my xbox connection; - Port forwarding and placing my xbox in the DMZ; - Switching router firmware (I have a ASUS RT-AC66u and I've tried DD-WRT, standard and Merlin); - I never have any problems with the MP of any other game; - I've downloaded all the patches obviously;

Does anyone recognize this problem?

  • 1
    Have you tried contacting Ubi's customer support? This seems like a problem with their server, seeing as other games work fine. Also, don't just DMZ your console, that's very unsafe. But you sound like you know that already ;) – Kevin Apr 28 '15 at 8:56
  • @Kevin, Yes I prefer port forwarding, but I've tried just about everything, to be sure. And I have contacted support and created a ticket. But I can hardly believe this is a bug of some sort that would affect only me. But stranger things have happened. Thanks for your reply. – Gerben Rampaart Apr 28 '15 at 9:01
  • Is there anything special about your internet configuration? Are you behind a symmetric NAT? Did you try turning on upnp? Is there a content filter somewhere along the line (some hotels etc do this)? – Kevin Apr 28 '15 at 9:06
  • I believe my internet config is as default as they come. Installing the router with new firmware or it's default firmware and clearing the nvram in the process I can't really think of anything that is out of the ordinary in my case. I've indeed tried enabling uPnp. It made no difference. And I don't have a content filter, I'm just your average Ziggo home user. The term symmetric NAT is new to me, I'll read up using the link you provided. – Gerben Rampaart Apr 28 '15 at 9:17
  • Symmetric NAT is mainly used for 3G or LTE, I don't think non-mobile lines use it, but I'm not sure. – Kevin Apr 28 '15 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.