2

Usually, when you hit escape during a mission, the game pauses and the menu pops up. I've just come back to playing KSP after about a year long break, and I'm encountering a bug that is pretty much game-breaking.

Very often when I hit escape, the game pauses but the menu doesn't appear.
I can do this infinitely many times, and the menu doesn't ever come back once it doesn't appear once.
I literally have to kill the KSP.exe process then reload the game in order to keep playing.
This is obviously quite annoying, and I've already pretty much screwed over my career mode because I can't to back to vehicle assembly once I've closed the game and I lose all that money.

Has anyone else experienced this issue or does anyone have any ideas as to what might be causing this issue?

I'm using Windows 10, 64-bit, Steam, KSP version 1.0.0.830, no mods, Nvidia graphics card with the most up-to-date drivers.
I've tried reinstalling, restarting my comp, messing with the game graphics settings, but nothing has worked.

4
  • Are you using 64-bit KSP?
    – SaintWacko
    Apr 30, 2015 at 17:55
  • @SaintWacko Yes I am, but I've tried 32 bit as well to no avail. Apr 30, 2015 at 19:32
  • Windows 10 is still in beta. That might have something to do with it...
    – AER
    Apr 30, 2015 at 21:43
  • What hardware do you have? I encountered a similar issue and it was something to do with my Logitech G13 gamepad. I ran into the problem in several games and found pressing shift+esc worked. Although that creates a problem if you have engines active...
    – Coomie
    Oct 22, 2015 at 8:48

1 Answer 1

1

Try running the game in compatibility mode for 8.1 (8 or 7 will do), windows 10 is still in beta and is not really recommended for any games yet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .