3

Whenever I run a game from http://gamejolt.com, Java prevents me from playing it. It tells me Java doesn't allow applets without an approved certificate. From what I understand, GameJolt's games are self-signed, meaning the creators signed their own games.

Downloading the game seems to fix it sometimes. Adding GameJolt to Java's security exceptions didn't work either.

Why won't Java let the applet run? What can I do to fix this?

I'm using Chrome on Windows 7.

7
  • 1
    What are your Java Security settings?
    – Ben
    May 1, 2015 at 1:58
  • They're defaulted to "High" right now.
    – unbindall
    May 1, 2015 at 2:03
  • Try dropping them down (if you can), see if that makes a difference
    – Ben
    May 1, 2015 at 2:04
  • Um... "High" is the lowest I can put it...
    – unbindall
    May 1, 2015 at 2:04
  • 1
    Risking security holes for video games... yep, sounds legit.
    – unbindall
    May 1, 2015 at 2:11

1 Answer 1

1

Chrome has dropped support for NPAPI plugins (Unity, Java, Silverlight self signed certs effected). You can re-enable NPAPI (but as of Sept 15 this will no longer work) :

Enabling NPAPI in Chrome Version 42 and later

As of Chrome Version 42, an additional configuration step is required to continue using NPAPI plugins.

In your URL bar, enter:

  1. chrome://flags/#enable-npapi
  2. Click the Enable link for the Enable NPAPI configuration option.
  3. Click the Relaunch button that now appears at the bottom of the configuration page.

This is only effecting Chrome so another way around it is to just logon to the site with Firefox, iExplorer etc.

More info here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .