0

I bought Witcher 2 during the Steam sales, and I don't know why I get so low FPS... My specs are :

  • MSI GE70
  • Intel i7 4700MQ 2.4GHz
  • GTX 765M 2Go
  • 8Gb RAM
  • HDD 7200 RPM

Low or High presets doesn't change anything !

  • 2
    Saying "high" computer while having a gtx 765m is wrong. – Y U NO WORK May 12 '15 at 11:15
  • Seconded. Although we don't provide hardware suggestions or the like, it's glaringly obvious in this case that your 765m is the weak link. – user66184 May 12 '15 at 12:46
  • With what @YUNOWORK said, you have a gtx 765m gfx card, so do not expect to much from it. The Witcher 2 is quite demanding – Oil May 12 '15 at 14:03
4

I'm not sure what you have tried to solve this problem, but my first thought would be to update your Nvidia Graphics drivers.

This is very unlikely but also try verifying your games files, maybe some essentials are missing. It will download the required files.

  • My drivers are already on the latest version ! – Zooly May 12 '15 at 22:48
  • Will try to verify my files :) – Zooly May 12 '15 at 22:48
0

Seems to be the NVidia 3D drivers that were not available for this game, and I should disable them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.