2

With a group of friends, we fired up our old copies of AoK to play together through LAN, as the HD version (through Steam) only offered unplayable games.

To play our "not so recent" games, we use an OpenVPN network I set up. This solution, while not being the easiest one to configure, is the most reliable one as it has a very small memory footprint and offers great pings.
With it, we've managed to play several games successfully. Up until the "Age" series.

So, few days ago, we installed AoK, patched it to the latest version and added "UserPatch" to the mix. We all have the exact same version.

We were 3 to do our tests, all on Windows 7.
Both my friends could see everyone's games, could host and join each other.
But as for me, they could see mine, I could see theirs, but the connection would always timeout either way.

So I did several tests:
- my firewall (software) was set to allow everything from AoK
- my firewall (hardware) was set to allow everything from OpenVPN (setting it off didn't change anything anyway)
- UPnP was off (unneeded for LAN anyway, apart from a rule for OpenVPN as I'm hosting the server)
- we're all using the same antivirus
- they both have the same router, I don't; I have a Speedtouch 780WL
- I tried switching on network-related services that were off, without success

As they could play with each other, I thought it was a network issue on my part, so I launched TCPView to see what was happening as they tried to reach my game.
I could see them trying to reach me, but to my surprise, the IPs shown on TCPView weren't the OpenVPN ones, but their external (ISP) ones.
So we did one more test: playing through Direct IP, using external (with proper ports forwarded) and OpenVPN IPs, instead of LAN, but this wasn't successful either.

So I'm clueless as to why it doesn't work. It's quite frustrating as I'm also the one who set up their computers.
The only thing that might differ is that I have a static IP for my own network (192.168.x.x), set in stone in both the router and the network card.
Though I don't know why this would cause an issue honestly.

Edit 1: Even when it works, TCPView still shows the external IPs, so it's probably not related.
Edit 2: I also tried hosting the OpenVPN server on a remote server instead, to see if that could cause the issue, but it ended with the same result.

  • 2
    What was unplayable about the HD version? I've had nothing but good experiences with it. – Studoku May 11 '15 at 10:52
  • @Studoku Freezes all the time. That's quite "funny" because we don't have these issues with other Steam games. – shroom May 11 '15 at 10:56
  • Dont play on work network. – Virusboy May 16 '15 at 3:28
  • @Virusboy We all play on our "home" computers if that's what you mean :) – shroom May 17 '15 at 10:21
  • @shroom No clue what was going on there, but maybe you would like to consider using GameRanger. It doesn't use VPNs, which I find quite troublesome. Also it shows ads in the lobby, but other than that it's a fine software. – RimaNari Oct 24 '15 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.