3

I installed the game today and everything went fine. And then I joined a server, played for a few minutes and quit.

After about an hour or two, I again started the game and joined some other server. The round started and when I tried to buy ammo by using the , shortcut key, I got reconnected to the same server that I had joined an hour earlier.

This made me suspicious and I opened my "config.cfg" file to see a series of "connect xxx.xxx.xxx" to the bind command in the file. I deleted that file and made it a readonly after restarting the game. But the problem still persists. Is there someplace else that I need to look and make the file readonly?

PS: I also re-installed the game and made the config.cfg, userexec.cfg, and GameMenu.res files readonly before starting the game. But the problem still persists even after a clean re-install.

  • also check binds. man, cs 1.6 servers edited binds to make ads with some buttons. thank god valve fixed it on cs:go. – Ave May 11 '15 at 19:56
  • I did check the binds in the config.cfg and userexec.cfg. Are there any more files where I need to check for binds? – asprin May 12 '15 at 4:17
  • Open up console (" or é) and write "bind ," (without " and the , being the button you search for) – Ave May 12 '15 at 19:47
  • @ardaozkal It came up empty :( – asprin May 20 '15 at 7:45
  • Try server browser? – Alexander M Oct 26 '15 at 5:00
1

Check UserConfig.cfg, if that fails try deleting all the config files. Run the game, set your settings then task switch out and set every .cfg file as read only.

I can't think of anywhere else this could be hiding. When you did the clean install did you manually delete all CS:GO related files? I don't believe that the clean install removes your configurations if you just remove local content.

| improve this answer | |
  • It's not CS:GO. Rather, it's CS 1.6 – asprin Jan 18 '17 at 15:20
  • The advice should still remain for 1.6, source or CS:GO. If you also make sure when you look in the config folder that it is set to show hidden files and show extensions. A common thing in general is to create config.cfg.txt and hide config.cfg (as an example). If show extension isn't set the user just sees a dummy config.cfg. – Dustybin80 Jan 18 '17 at 15:33
0

Check autoexec.cfg for any other config files that may be the cause of the spam binds.

You might also want to try "Set to default" option in the keyboard control settings

| improve this answer | |
  • Already checked that file. It was blank. Also tried "Set to default" option. That didn't work too – asprin Jun 10 '15 at 14:23
-1

I'll be blunt it is most likely that the game you have downloaded searches for community games first other than taking you to a server that is used country wide if there are no local server's in their community.

| improve this answer | |
  • But I've a legal copy. I downloaded it from Steam...so I believe there isn't a chance of having something fishy in the game setup file – asprin May 12 '15 at 4:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.