5

I've just got round to playing Bioshock 2 and I've been getting through it fairly well, despite the fact that the graphics strain my system.

I've just got through the Pink Pearl in Siren's Alley, and put the code into the door to get to the pumping station. They cut the power and all hell broke loose.

However, before I get the chance to defend myself, the game crashes. It's replicable and I can't seem to get the game to get past that point. It has a brief freeze and then crashes to desktop with no specific error.

I use Windows 8.1, 8GB RAM, i7 3630QM, GeForce 740m.

All my drivers are up to date, the game is up to date, I have tried verifying the integrity of the Steam cache.

What can I do to progress past the point of this crash?

8
  • 2
    I'm not familiar with the windows version of Bioshock 2 (or Windows 8.1, for that matter), but here are some generic tech questions which would help: What are your computer specs? Are your graphics and sound drivers up to date? Is Bioshock 2 up to date? With any luck that should help diagnose this issue.
    – two bugs
    May 14, 2015 at 20:05
  • Edited info into question.
    – shanodin
    May 15, 2015 at 7:31
  • No specific knowledge of the issue, but take a look at this Steam community post: Crashing of Bioshock 2 Solved: If your game just randomly closes itself without ANY error message whatsoever or even crashes on START - this guide is for you.
    – Samthere
    May 20, 2015 at 15:20
  • Tried running it in compatability mode?
    – Sam
    May 20, 2015 at 15:40
  • It's a savegame issue, most likely. Just in case, you did obtain the code inside the game right? I mean the piece of paper appears when you use the keypad?
    – Zerjack
    May 20, 2015 at 16:52

1 Answer 1

2

When a game keeps crashing at a specific point, specially at special events. There are three possible causes.

  • The game is bugged at that specific point.
  • The game ask for too much resources at that point, and OS decides to shut it down.
  • The current save has corrupted data, and thus the game crashes when that data is read.

Given that Bioshock 2 is an old game the first issue is quite unlikely to occur, as the game would be patched by now.

When the second issue occurs it's happening on an OS level so the crashes tend to be more severe, like game freezing, or OS freezing.

So the most likely cause of the problem would be a save game issue. At some point the game saved corrupt data in the save file, and although the savefile is loading properly, such data will cause problems when the game tries to read it.

By OP's comment, a save game issue turned out to be the cause of the problem.

1
  • It's 2021 and the game repeatedly crashes in Siren's Alley. My PC is brand new with good specs, so I rule out 'too much resources'. (Siren's Alley does not look more resource-hungry than previous levels anyway) The save game I tried starts with the cutscene of the train going there, it's hard to imagine a corruption of the saved game is the reason since it basically only contains my inventory, the level itself is untouched. Therefore, I strongly believe that yes, the game still contains a crash bug in Siren's Alley. Mar 4, 2021 at 22:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .