2

I have been trying several times to install Hearthstone via Amazon app store on stock Samsung Note 4, but they all failed with error message:"There was an error while installing Hearthstone: Heroes of Warcraft. Please try again." So there isn't any useful information there.

The reason I want to install via Amazon is that I want to buy packs at a discount. More information on this can be found in these links http://www.amazon.com/b?node=10558189011 and http://www.trumpfans.com/how-to-purchase-hearthstone-packs-at-a-discount-through-amazon/.

The Note 4 is the only android device I have. It is from Verizon and I don't have root access.

  • Is it being downloaded to a SD card or directly to the phone, and how much space is left on the download location? – NBN-Alex May 19 '15 at 23:23
  • I don't have an sdcard yet, so it is installed to the phone. I have 15GB left. – warriormole May 20 '15 at 2:56
  • so this might not be the answer, but can you try out the steps here to delete the Amazon app cache? Link here Even though you do not have an SD card yet, the root folder may show as "sdcard0" as some phones will emulate this spot in place for the on-board memory. If the files do not show up on the PC, check again using a file explorer like "Explorer" on the phone directly. – NBN-Alex May 20 '15 at 21:19
  • Thanks. But there is no files (after showing hidden files in ES File Explorer) under the cache folder "\sdcard\Android\Data\com.amazon.venezia\cache" – warriormole May 21 '15 at 18:57
  • drat, try this link then. -Solved- Amazon Appstore Won't Download. The problem "could" be that the permissions for the Amazon app is messed up, which in turn makes it impossible to download/install from their own app store. You won't need root for this, just uninstall the app, check the folder and rename it if it still exists, then reinstall the amazon app. – NBN-Alex May 21 '15 at 23:03
1

There is still currently an issue with Android, the Authenticator, Amazon Appstore, and Hearthstone. Blizzard attempted to fix it but some users are still having an issue.

Blue post: http://us.battle.net/hearthstone/en/forum/topic/16860656703?page=3#44

I also unlinked my authenticator, uninstalled the app, installed Hearthstone through Amazon Appstore, then reinstalled authenticator, and finally linked authenticator to account again. Annoying but works.

0

It is because you have the Blizzard authenticator installed on the same device and the Amazon appstore doesn't let you because of this for some inane reason.

  • 3
    Do you happen to have a source for this? That seems kinda unintuitive, two unrelated applications conflicting like that. – Frank Jul 26 '15 at 19:49
  • Uninstalling the authenticator solved the issue for me, not sure why this is getting downvoted. – Cheddar Aug 9 '15 at 3:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.