3

I have a gaming laptop and my drivers are updated. Usually, I'm playing with 200+ FPS, but since the last CS:GO update, when a smoke pops on the screen I drop to 30-40 FPS. I'm playing with an AWP and when I zoom in it is horrible!

3

Since the "one-way smoke fix" smoke effects have become extremely demanding on GPUs pixel fill rate.

Most likely the problem is the quite poor pixel fill rate (13.6 GPixel/s) of the GTX 765M. In comparison to the GTX 770 with 33.5 GPixel/s or even the 4 years old GTX 570 with 29.3 GPixel/s.

The only fix is to lower your resolution.

  • Will try this solution, but I'm playing on 1600x900, instead of 1920x1080 because I prefer to play like this. I don't know which resolution could I chose if I want to keep graphical quality and perfect crosshair. Will give you a feedback :) – Zooly May 28 '15 at 9:31
0

You could try using a different DirectX level (Command Line Options)

-dxlevel  - Forces a specific DirectX version when launching the engine. This is useful if your graphics card is DirectX 9 capable, but a lot faster using only DirectX 8 (e.g. NVidia GeForce FX 5200). Multiply the desired DirectX version to use with ten. E.g. for DirectX 8.0 you would use -dxlevel 80. For DX9 there are three possible values depending on the Shader Model the graphics card supports. Seemat_dxlevel.

  • Thanks for advise :) I will try ! But it seems me strange because before some updates of the game, I didn't have issues like this ! And I've never launched a game on D8 haha ! I have a GTX 765M 2Go, I can run GTA V easily etc. – Zooly May 20 '15 at 12:42
  • @HugoTor Might be some updates to the shaders that for some reasons are causing a slowdown. Good luck! – m-p-3 May 20 '15 at 12:43
  • Maybe I should wait for the next update from NVidia or Valve.. ^^ – Zooly May 20 '15 at 12:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.