0

Civilization V keeps crashing on me. I've now had several games that suddenly crash while processing a specific turn (same turn every time). The crash usually happens during the early parts of the game, while I still have civilizations left to discover. I'm also running some mods from the Battle Royale collection. This makes me suspect buggy mods are at least part of the cause.

The strange thing is that the same crash also happens every single time I load a game from within another game, AND every single time I click "Exit to Main Menu" or "Exit to Windows". So that makes it hard to blame everything on the mods...

Now, a crash while loading a game from within a game could be caused by insufficient RAM I suppose, but that shouldn't matter when exiting the game, right?

I've already tried disabling leader heads in my config.ini (didn't fix it), and I've tried to verify the integrity of game cache in Steam (6 files failed to verify and was reaquired, but still didn't fix it), and I've made sure I have the latest GeForce drivers (350.12) and DirectX version.

Any help would be greatly appreciated!

My specs:

Windows 8.1 Pro 
Intel Core i7-2600k 
8GB RAM 
GeForce GTX 970
  • 1
    Why don't you try playing with the mod off? You would be able to test if it's caused by the mod or not. – Izzo May 19 '15 at 12:03
  • 1
    Related question, and maybe even a duplicate: gaming.stackexchange.com/questions/11833/… – Izzo May 19 '15 at 12:04
  • @Izzo Yup, I should try a game without mods just to make sure, but it would be very time consuming and I'm still very demoralized after last time it crashed. – o01 May 19 '15 at 12:14
  • @Izzo I tried the solution provided in the question you're referring to, but to no avail - the game still crash on the same turn - despite switching to strategic view. – o01 May 19 '15 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.