1

I have turned on sv_cheats 1 and run nav_generate on the server. Then I set nav_edit 1 from within TF2 (client-side), but no mesh appears. I've added bots, and they clearly follow the generated nav, so it does exist, I just can't see it.

I've followed this tutorial and looked at various guides and forum posts, but no luck.

I've tried turning on nav_edit 1 on the server side instead, but it starts an infinite loop of error messages saying:

UTIL_getlistenserverhost() called from a dedicated server or single-player game

I've tried different maps and different map types, no difference.

I've tried two different computers, no difference.

What am I missing or doing wrong? Is there a graphics setting I need to change, maybe?

1

Figured it out. Instead of connecting to a remote server (even one that happens to be on the same machine or accessible over LAN), I needed to start a server from within TF2 client.

When I did it that way, nav meshes showed up and were editable as per the linked tutorial.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.