0

I used this to place redstone:

/setblock -624.5 244 -1692.5 redstone 0 replace

It gives an error saying that there is no such thing as minecraft:redstone. I tried many different things and nothing works. How can I make a command block place redstone?

4

The are two reasons why this command probably isn't working:

  • First, you can't have decimals with the co-ordinates of this particular Minecraft block. They have to be whole numbers not decimals. Try placing a block where you want the redstone to be, look at it, press F3. You will see the co-ordinates of the block in the top right hand side. (See 'looking at'). Destroy the block and use these co-ords in the command.
  • Secondly, the id for redstone dust (the block) is minecraft:redstone_wire, as the inventory item is minecraft:redstone
  • Great! But decimals don't do anything except for reducing the tick delay (this also helps with ghost blocks) and that was not the error I was talking about. Thanks though. – Louis May 24 '15 at 0:35
  • If it helped, click the grey tick below the votes. Thankyou! – angussidney May 24 '15 at 0:39
  • I couldn't for 10 minutes. Also, it's not an dumb question, why did you downvote? – Louis May 24 '15 at 0:47
  • I didn't downvote. That was someone else. – angussidney May 24 '15 at 0:48
2

Adding on to Angus' answer, there are also 16 different states for redstone wire, which you can specify using the data value.

This is because: 2^4 = 16-1 = 0 to 15.

-2

Try putting in:

/setblock -624.5 244 -1692.5 minecraft:redstone_block 0 replace

It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.