2

I have a problem with running WWE 2k15. It goes in some kind of slow motion mode when the main game starts (entrance). This is annoying. I have a laptop on which I play.

Laptop specs:

  • Intel core i7 4core 2.2 ghz
  • 64 bit
  • 6gb ram
  • Nvidia 540m 2gb
  • 1tb hard drive
  • intel hd graphics
  • Windows 8.1

I am able to play games like Far Cry 4, Battlefield 4, Crysis 3 properly without any lag or any other problems.

8
  • Check your settings in case the frame rate is capped really low. Otherwise change the settings, change everything to low or off and see what happens. Also make sure this isn't an audio problem, some games try to sync to broken audio. – CrabtasticGoat May 25 '15 at 23:51
  • The game doesn't has any option to change framerate – Tom May 26 '15 at 4:12
  • Apparently this is a problem a lot of people have... Try this – CrabtasticGoat May 26 '15 at 4:23
  • This just worked for me, hopefully it works for you as well if the game doesn't see your NVidia card in a laptop. If you go to the game's local files, right click on the executable, go to Run With Graphics Processor, then click Change Default Graphics Processor. This will take you into the settings of Windows, and there you can set a global choice for graphics processor, or tell WWE to look specifically at using your NVIDIA. Hopefully this helps! – CrabtasticGoat May 26 '15 at 4:23
  • If even this doesn't work, try turning off V-sync and Shadows and enable depth of field. – CrabtasticGoat May 26 '15 at 4:24
1

Do you have optimus nvidia technology ? If yes, install Nvidia control panel, select your game and enable performance mode. Some games somehow use intel graphic card by default. I had the same issue with Killing Floor 2, low graphics, overheating and slow motion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.