2

Whenever I start an Unturned Server, my friends can join it over Hamachi without a problem. Same way with Magicite, we can play together with no issue. But whenever we try to join a Minecraft Server I started it says java.net.ConnectionExeption: Connection timed out: no further information: And they can't join.

I am properly launching a Minecraft.1.8.6.exe server not just Opening it to LAN. I had my friend host a server and I was able to connect without a problem but he says it slows down his computer too much, so we aren't able to play Minecraft together. I have had several friends try to connect from several different computers, and they had the same problem. my LAN Minecraft games work OK, but it is just Hamachi hosted games. Any way to fix it?

I am assuming it'd have something to do with my Hamachi Network Adapter, or my Firewall. I have inbound, outbound, and Gateway rules set for hamachi-2-ui.exe so I wouldn't think it would've been my firewall.


EDIT: I had my Hamachi connection set as a Public connection and Public Networks don't have the rights to inbound connections, so by setting it as a Work/Home connection fixed the problem.

  • A search of dupes brings up this one. Any chance that might help you? – Frank May 27 '15 at 22:50
  • @Frank I didn't find anything that worked – Eisler 485 May 31 '15 at 22:19
  • 1
    Hamachi randomly not working as intended? Sounds like time for setting obscure values in the adapter config! Go to your Network settings -> "Change adapter settings" (sidebar), right-click Hamachi -> "Properties". In the list, double-click "Internet Protocol Version 4", open "Advanced". In the first tab, there is a setting for "Metric". If not set to automatic, set it to automatic and try. Else, unset automatic and set it to 1. (It's a long shot and I'll make this an answer only if it works) – MrLemon Jun 1 '15 at 9:01
  • 1
    Check, and delete all the inbound/outbound rules related to javaw.exe, and the next time it prompts, try to allow it across the firewall. It may solve the problem! – Rajat Jain Jun 3 '15 at 4:17
  • 2
    @Eisler485 Glad to hear you solved your problem! You should add your 'Edit' solution as a separate answer, not into the question body :) – Robotnik Jul 13 '15 at 1:42
2
+50

Try going into

  • (On Windows 7/8) Control Panel -> Network and Internet -> Network Connections
  • (On Windows XP) Control Panel > Network and Internet Connections

You should see a bunch of icons for your different network connections.

  1. Go into the menu at the top (if it is hidden, press the Alt key to show it). This is the menu that says File, Edit, View etc.
  2. There should be an 'Advanced' dropdown. Click that, and select Advanced Settings.
  3. Using the up and down buttons, move your Hamachi network connection to the top of the list.

Then try again. This can sometimes fix issues with Hamachi not working correctly.

  • While I was going through you're steps i noticed that I had my Hamachi Network set to "Public" and on my Computer I have my fire wall on, when it comes to Public networks. So by setting it to a "Home Network" May fix the problem. – Eisler 485 Jun 8 '15 at 1:25
2

Ok so a couple of things.

  1. Check your firewall in case that is stopping it
  2. Have you set up the server right? You obviously know how Hamachi works, so you know about the IPv4 to use as the ip right? Well you need to go into the server settings and copy and paste your IPv4 adress into the option in there that says 'server-ip=' paste that there. This might be what you're missing, also keep the server application open (The console) When you close that the server stops.
  3. Double check they're joining the right ip (IPv4 address)

I've set up quite a few Hamachi servers so this is from first-hand knowledge learnt from a lot of time researching :)

Hope this helped you

  • Don't be those people who don't care about the bounty. Get It! – Universal Electricity Jun 4 '15 at 17:20
  • How do I get the bounty? I'm new to stackexchange :P – Skye Jun 4 '15 at 17:45
  • 1
    Be patient, wait for 3 days, improve your answer and get the bounty! – Universal Electricity Jun 4 '15 at 18:02
  • I know how to use Hamachi... I stated that I do indeed know how to connect to my friends' servers but they can't join when I host. – Eisler 485 Jun 8 '15 at 1:21
  • Then have you checked your firewall? – Skye Jun 9 '15 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.