I recently added a Cargo Harbor to my city. After a bit of time, I had a TON of traffic to and from it. Great!

Then something happened. It I haven't seen a cargo ship in days (IRL). No more traffic. Then, as a consequence, ~50% of the commerce in my city has shut down for lack of supplies. I need my cargo ships back. Why did they leave? How do I get them to return?

  • 1
    Is there any part of your water connection where the water has dried up? Perhaps where there are a lot of water pumps sucking it all up? A recently built dam?
    – JMR
    Commented Jun 8, 2015 at 12:57
  • 1
    I have no rivers - only oceans - so nothing is dry. I just reset my cargo harbor (relocated and place in the same spot) just in case the ocean water level went down. Hopefully that will do something.
    – Jeff
    Commented Jun 8, 2015 at 18:59
  • FYI - Resetting my cargo harbor had no effect.
    – Jeff
    Commented Sep 16, 2015 at 14:57
  • Is there any chance that there are obstructions in the water near the harbor that would prevent the ships from being able to dock?
    – Tim S.
    Commented Oct 29, 2015 at 22:33
  • I don't have that city anymore so I cannot check. However, it was an ocean port and the shoreline was straight. I cannot imagine that anything was blocking it - especially since it was a busy port at one point.
    – Jeff
    Commented Nov 2, 2015 at 20:19

1 Answer 1


I had exactly the same issue and it was caused by a broken road connection to the harbour that was impossible to see without removing the harbour. Vehicles passed the harbour as expected but it was impossible for them to enter the harbour because the road was laying above the piece of roed that belongs to the harbour. But that was invisible. During construction I used traffic++ and overlapped the roads in order to create a nice industrial harbour sea wall. I made some refining work after the harbour initially worked. This I assume brought up the issue that the road connection of the harbour asset was not realized correctly. After removing and re-building the harbour it worked again. I struggeled with this for days as well, looking for obstacles in the water, increased the water depth, turned the harbout off and on again... before I decided to break it down and start from scratch.

  • This sounds like it could have been the issue. I do remember that I was playing around quite a bit with the harbor road. Unfortunately, I dont have the city anymore to test and be sure.
    – Jeff
    Commented Jan 5, 2016 at 15:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .