1

I was editing the essentials config for my server, and I restarted it and all of a sudden pex prefixes aren't working. I didn't change anything in the EssentialsChat part, its all normal. I even tried reloading pex and essentials.

I put the permissions file through a yaml parser and no errors. When I do /pl all plugins are functional. I think one of the plugins did it, but I don't know which one.

My plugins are:

  • World Edit
  • World Guard
  • Essentials
  • Permissions Ex
  • aAntiSpam
  • Gods
  • Jobs
  • BOSEconomy
  • ClearLag
  • MCMMO
  • Announcer
  • Factions
  • Lockette
  • Vault
  • EnjinMinecraftPlugin
  • Multiverse
  • RandomTP
  • Please post your permissions.yml. – user112881 Jun 5 '15 at 12:50
1

You may be interested in this part of the essentials config (at the very beginning)

# Disable this if you have any other plugin, that modifies the displayname of a user.
change-displayname: true

# When this option is enabled, the (tab) player list will be updated with the displayname.
# The value of change-displayname (above) has to be true.
change-playerlist: true

# When essentialschat.jar isn't used, force essentials to add the prefix and suffix from permission plugins to displayname.
# This setting is ignored if essentialschat.jar is used, and defaults to 'true'.
# The value of change-displayname (above) has to be true.
# Do not edit this setting unless you know what you are doing!
#add-prefix-suffix: true

The comments are good explanations for each setting.

These are the current settings in my config, but mine are different because I'm using Herochat. My suggestion is to fiddle with these settings until it works. Not a great answer, but it should fix your problem.

0

The problem is that Multiverse overrides PermissionsEx prefixes. If you look into Multiverse's config there should be an option to disable it's prefixes.

0

MAKE sure you do it like this

groups:
  aUser:
    options:
      prefix: '[prefixuwant]'
    permissions:
    - allmy.permissions

NOT like this

groups:
    aUser:
    '[thisISdaprefix]':
      options:
        prefix: add

also make sure essentials + essentails chat are both installed and running

also your plugins:

its NOT (used these fine with pex before):

World Edit
World Guard
Essentials
aAntiSpam
ClearLag
MCMMO
Factions
Lockette
Vault
EnjinMinecraftPlugin
Multiverse
RandomTP

it COULD be (not saying are):

Gods
Jobs
BOSEconomy
Announcer

try to remove ALL above plugins and see if it is fixed? (if first dosent work or dosent apply)

-1

Your need these 3 jars: Essentals.jar EssentialsChat.jar EssentialsSpawn.jar download install these it will fix it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.