3

(This is a follow-on to an earlier question whose answer taught me about spawn chunks.)

I've built an iron golem farm in Minecraft, and I've noticed that golems don't spawn when I'm far away from it if I'm using OptiFine, even though the farm is located within the "spawn chunk" area that should always be loaded. If I switch to vanilla Minecraft without OptiFine, the farm works properly even when I'm far away. It also works under OptiFine when I'm near the farm.

I'm running Minecraft 1.8.4 with the official Mojang launcher, and OptiFine 1.8.4 HD D4 Ultra. No other mods. The farm is basically right next to the world spawn point; the whole thing is within about 40 blocks of it. I'm traveling to a distance of about 600 blocks for testing "far away". I'm staying entirely in the overworld, so the Nether isn't involved.

With vanilla, my farm produced about 40 iron in about half an hour while I stood at a distance of roughly 600 blocks. With OptiFine loaded, it produced zero iron in an entire hour of idling at the same distance. Items dropped on the ground did disappear, though, so it seems that the farm's chunks are still loaded at least to some extent under OptiFine.

Is there a way I can fix this? I want to use OptiFine for its connected textures and anisotropic filtering, but I also want my iron farm to work. As a guess, I tried turning off OptiFine's "lazy chunk loading" setting, since the tooltip says that turning it off gives you "default server chunk loading", but it didn't make a difference.

  • Optifine for 1.8.4 has just been released, so maybe buggy, I am also using OptiFine, and have many mechs at spawnchunks, no problem at all ;-D – Rajat Jain Jun 3 '15 at 4:21
  • FWIW, I tried OptiFine HD B1 Ultra for Minecraft 1.8.3 and it seems to have the same problem. So it's not specific to the 1.8.4 version. – Wyzard --Stop Harming Monica-- Jun 3 '15 at 4:47
  • 2
    isn't optifine supposed to help reduce lag and improve performance? so wouldn't spawnchunks, which are loaded always, be a drag on the system? – Bob Jun 3 '15 at 6:36
  • I would assume Optifine disables (or at least cuts down on) spawn chunks being constantly loaded. – user109232 Jun 7 '15 at 20:32
2

The Smooth World option in the Optifine performance settings allows spawn chunks to unload when you are faraway. If you want iron farms to keep working as long as you are in the overworld, turn Smooth World OFF.

0

I tried a bunch of earlier revisions and found that spawn chunks seem to work correctly in OptiFine 1.8.0 HD U A3 and A4, but not in later versions. I'm assuming it's just a bug that was introduced in version A5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.