Alright, My game used to be just fine on my computer.

I used cheats a lot, so the "/gamemode" cheat I already tried it, and it doesn't work, just throwing that out there first.

Alright, well, I go into Survival Mode and I try to destroy a block, and I destroy it, and It disappears for a second and it comes back? Also lags..

I've tried, the cheats, I've gone into controls, I've completely erased all the data from the ".minecraft" folder, and then deleted the game, and reinstalled it. It's just not working, and frankly making me very angry.

What is happening?

  • Does the whitelist apply to singleplayer..?
    – Ben
    Commented Jun 3, 2015 at 23:19
  • You've said you tried changing the game mode in cheats, which game mode are you using? I've encountered this issue before, and it was because I was setting my game to adventure game mode (/gamemode 2), and not survival (/gamemode 0).
    – onewho
    Commented Jun 4, 2015 at 13:04

2 Answers 2


It sounds like you are just having severe lag. Why this happened suddenly, I'm not sure. In console, do you see any errors? Possibly this:

[Warning] Can't keep up! Did the system time change or is the server overloaded?

If you do, start by backdating to 1.7.10 and installing a mod called FastCraft, and possibly Optifineas well.

If you do not know how to install mods, start here.

Download Optifine (Make sure you download the 1.7.10 version!) and FastCraft (It is not currently updated for 1.8, so you don't have to worry about the version.) and move them into the mods folder in .minecraft.

If backdating to 1.7 fixes it, it's probably the 1.8 update; it is pretty well known that 1.8 is very laggy and unoptimized, despite the new additions such as VBOs in Video Settings.

If backdating did not fix it, try uninstalling all versions of Java and installing the latest Java 8 version.


I HAD THE SAME PROBLEM. I fixed it with the gamemode cheat, so you may have used too many cheats in the past which causes a lot of lag. Updating to 1.8.6 helped me, though, that's the newest update to date and will probably fix the lag.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .