0

I am making a parkour map in Minecraft and I don't want players to be able to teleport. Is there a way to block players from using this command?

1

Yes, there is a way. When you make the world, you can select Creative mode with no cheats. Now when the world is loaded, entering commands like /gamemode 1 will result in a message saying you don't have permission to use that command. So there is this feature where you can enable cheats in a non-cheat world. Go to the pause menu, then "Open to LAN". From there, select "Enable Cheats". Now you have access to cheats. Note that this cheats mode is temporary, once you quit the world, cheats is deactivated. When building the map, you get access to commands like /give and /gamemode. When you give out the map, the players do not get access to the commands.


TL; DR

To a certain extend, yes you can do that. However, if the players find out about this feature, they can abuse it. Perhaps what you could do is have a armour-stand tracking system and detect a player who teleported away and teleport them back.

0

Try this:

By using NBTExplorer:

  1. Navigate to %appdata%\.minecraft\saves; 2. Find the folder with the name of your world. Copy the file at that folder (don't move it to the desktop.); 3. Download NBTExplorer. Link here: https://github.com/jaquadro/NBTExplorer/releases/tag/v2.8.0-win . Download the zip version of it. Extract it to your desktop after download.; 4. Open the .exe file with the deadbush icon. Find the copied world, it will show as its exact folder name. Click the + button beside the folder's icon to expand.; 5. Now that you expanded its contents, using the + button, navigate to level.dat, then to Data with exactly 39 entries (unless you have added something there already). After navigating inside Data, find a tag named allowCommands without expanding anything. If commands are allowed in that world, its integer should be 1. To disable commands, change it to 0 by double clicking it and editing its value to 0.; 6. Open the copied and modified world and try to use a command. If you cannot use any command because it says "You don't have permission to use this command", then it is a success, there goes what you desired :), else, notify me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.