3

Well I searched for a while but I did not find what I expected to, so I come here to ask something about Minecraft and the Bukkit Servers.

Here's the deal:

I'm actually setting up permissions with Essentials GroupManager plugin but when I try to deny permission nodes, it doesn't work.

For example:

Guest:
    default: true
    permissions:
    - -bukkit.command.kill
    - essentials.build.interact.324
    - -essentials.build.break.12
    - -essentials.build.place.12

I reload my server and then try to break a sand block. What happens? The sand block still breaks and the door opens. So I think that the problem comes from the negative permissions. I tried with many permission plugins but resulting to the same thing, however the "- -bukkit.command.kill" works, that's really frustrating...

I really hope you could help me, thank you.

EDIT:

Well I tried what you told me, TrivisionZero, and now it woks as well as I wanted it to.

I just have a little problem now:

Guest:
    default: true
    permissions:
    - -bukkit.command.kill
    - -essentials.build.interact.23
    - -essentials.build.interact.25
    - -essentials.build.interact.54
    - -essentials.build.interact.58
    - -essentials.build.interact.61
    - -essentials.build.interact.84
    - -essentials.build.interact.116
    - -essentials.build.interact.130
    - -essentials.build.interact.137
    - -essentials.build.interact.138
    - -essentials.build.interact.145
    - -essentials.build.interact.154
    - -essentials.build.interact.158
    - -essentials.build.interact.328
    - -essentials.build.interact.333
    - -essentials.build.interact.342
    - -essentials.build.interact.343
    - -essentials.build.interact.354
    - -essentials.build.interact.355
    - -essentials.build.interact.356
    - -essentials.build.interact.379
    - -essentials.build.interact.404
    - -essentials.build.interact.408
    - -essentials.build.interact.416
    - -essentials.build.interact.422
    - -essentials.build.craft.*
    - essentials.build.interact.*

I noticed my plugin not to allow interactions with Brewing Stands (379), Minecarts with Hopper (408), Storage Minecarts (342), Minecarts (328) and Redstone Repeaters/Comparators (356/404) but I still can interact with. Do I have to write special Datas or anything like that?

  • Hmm... As far as I had remembered, Group Manager does not support deny nodes... – aytimothy Jun 6 '15 at 16:07
  • Well it seems to do the trick now ^^ – Zanmyr Jun 6 '15 at 16:45
  • Then don't forget to mark the below answer as correct if it has helped you. (The rock below the downvote arrow) – aytimothy Jun 6 '15 at 18:10
  • Like I said, now I've got a problem with Minecarts and redstone components we can interact with. They are allowed even if I said it has not to be. – Zanmyr Jun 7 '15 at 11:46
  • Also, @Zanmyr - Arqade isn't a place of follow-ups. You might as well post your edit as a new question. Also to point out: A minecart isn't a block. It's an entity. – aytimothy Jun 7 '15 at 11:49
2

Make sure that you are not OP'ed, that you are in the "Guest" group, and have the AntiBuild plugin installed.

To make sure that the AntiBuild plugin is compatible with your server setup, do:

 /pl

If the plugin is highlighted in red, or not in the list, you may need to update a build (Bukkit, or the actual plugin).

If everything seems to be setup correctly, and you still can break blocks that you denied access to in the permission file, then make sure you don't have any user level permissions. Go into the "users.yml" file and check if you have any specific permissions assigned to your player, like "essentials.*", or something of the sort.

If you do, be sure to remove them. You can also get a temporary account on your server to test the permissions on, as you may have some kind of permission set somewhere.

An alternative to this, though you can't deny specific blocks, is WorldGuard. After installing, try these commands:

/rg flag __global__ construct deny

/rg flag __global__ build deny

A simple test I'd like you to perform is this; while on your server, try to use the "/kill" command that you want to deny. That worked? Hmm. Then Try "/say Hello". If that worked, then like I said, you may be OP'ed (which means that no permission will affect that), or in another group than "Guest".

DeOP yourself with the console and place yourself in the Guest group, now try the permissions. You may find that they are now taking affect.

Let me know if it still isn't working for you.

  • Thanks for the answer, it really helped me, now I can interact with Doors or Levers or Buttons etc, but not Dispensers or Enderchests, etc (like I wanted to) but please look back at my post, I edited it because now I've got a new problem with Minecarts and Redstone components. – Zanmyr Jun 6 '15 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.