5

I've previously installed Pocketmine on my OS X machine and had no trouble with Minecraft PE clients connecting to it on the local area WiFi and also over the internet.

Yesterday I installed the current version of Pocketmine-MP on a Raspberry PI and also on the same OS X machine that I'd previously had success with. When I run the server, it identifies itself with the version line:

This server is running PocketMine-MP version 1.4.1-980 "絶好(Zekkou)ケーキ(Cake)" (API 1.11.0)

However, in the Minecraft PE server list, neither of these local servers show a green light to the right, where as other servers on the internet do.

When I try to connect to either of these servers from a Minecraft PE client, the connection does manage to "partially" connect. First "Generating World" and "Locating Server" are shown, and then after a couple of seconds, the "Cancel" button is added.

If I hit the "Cancel" button, then I get a line in the server's log:

09:17:07 [INFO] [/80.44.205.83:54232] logged out due to client disconnect

So some kind of connection is being started but not completing.

Also, if I stop the servers, then the connection immediately fails and the client shows an error message.

My player name is "tobi-bobo" (no spaces). I've also tried just "tobi". I noticed that players/ remains empty. No files created for the name I connect with.

These is server.properties in full:

#Properties Config file
#Sun Jun 7 09:19:36 UTC 2015
server-name=LovelyWorld
server-port=19132
memory-limit=512M
gamemode=0
max-players=10
spawn-protection=16
white-list=off
enable-query=on
enable-rcon=off
motd=Welcome to Lovely World!
announce-player-achievements=on
allow-flight=on
spawn-animals=on
spawn-mobs=on
force-gamemode=off
hardcore=off
pvp=off
difficulty=1
generator-settings=
level-name=world
level-seed=
level-type=DEFAULT
rcon.password=bAeyNEzeCt
auto-save=on
debug.level=4

I've tried a few Minecraft PE clients running Minecraft PE 0.11.1: An iPhone 5 and an iPad. They can connect to other servers on the internet no problem, but not my PocketMine installations.

I've tried a direct connection within the LAN, and also by using noip – the results are the same – it doesn't complete the connection, but I do get a disconnect message in the server log.

Here's the full Pocketmine log:

09:08:53 [INFO] Starting Minecraft: PE server version v0.10.5 alpha
09:08:53 [INFO] Loading pocketmine.yml...
09:08:53 [INFO] Loading server properties...
09:08:53 [INFO] Starting Minecraft PE server on 0.0.0.0:19132
09:08:53 [INFO] This server is running PocketMine-MP version 1.4.1-980 "絶好(Zekkou)ケーキ(Cake)" (API 1.11.0)
09:08:53 [INFO] PocketMine-MP is distributed under the LGPL License
09:08:55 [INFO] Preparing level "world"
09:08:56 [INFO] Starting GS4 status listener
09:08:56 [INFO] Setting query port to 19132
09:08:56 [INFO] Query running on 0.0.0.0:19132
09:08:56 [INFO] Default game type: SURVIVAL
09:08:56 [INFO] Done (3.942s)! For help, type "help" or "?"
09:17:07 [INFO] [/80.44.205.83:54232] logged out due to client disconnect

Thanks.

3

The main issue here is that the currently stable PocketMine release that you're using (which is 1.4) only works with earlier versions of the Minecraft PE client.

You're going to need to install the currently unstable developer release of PocketMine, which is 1.5. This supports the new protocol used my Minecraft PE in 0.11.1.

When you come here and read this, they may have a stable build, but to get the unstable build for Raspberry PI, you should go in to your PocketMine folder and type:

wget -q -O - http://get.pocketmine.net/ | bash -s - -v development

This will pull down and run the PocketMine installer and tell it to install the latest dev build.

For me, this blew away the PHP5 installation that PocketMine keeps in its bin/ folder, so I needed to re-install this.

I did…

cd bin
wget http://sourceforge.net/projects/pocketmine/files/builds/PHP_5.6.4_ARM_Raspbian_hard.tar.gz
tar xvf PHP_5.6.4_ARM_Raspbian_hard.tar.gz
mv bin/php5/ ./
rmdir bin

And then, from the PocketMine root folder I did ./start.sh and my Minecraft PE clients could connect.

A quick note on user names – I wasn't able to connect using a name containing a hyphen like tobi-bobo. tobi worked okay though.


I got this information from the PocketMine forums where there is a discussion thread on this topic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.