After the steam update I tried hiding some unwanted steam games in my library but they always come back after I restart steam.
Basically I hide them, then it's all perfect there out of the way. But when I open steam again they're back out of the hidden category. Does anyone know why this could be happening?
I tried deleting ClienRegistry.blob and running steam://flushconfig, but it still didn't help.

  • Are you using the stable or the beta builds of the client?
    – aytimothy
    Jun 7, 2015 at 11:42
  • @aytimothy The stable build, but actually it work with steam games, just not with non-steam games. I don't want to delete them from the library because I want to launch them from other shortcuts, I just don't want them showing up in the library.
    – user114790
    Jun 7, 2015 at 20:15
  • It could be the way hidden games are stored; settings are synced to the cloud, and since noon-steam games obviously aren't stream games, Valve servers won't accept it. Actually. Let me ready this out.
    – aytimothy
    Jun 8, 2015 at 2:19

1 Answer 1


The problem seems to be that non-steam game shortcuts can't be hidden. If you're having trouble hiding actual steam games, I'm afraid I have no solution to that.

Refer to the (second) comment by @aytimothy

  • If you're wondering why I was trying to hide non steam games instead of just removing them, it's because me from a year and a half ago (or to be exact 1 year 4 months 26 days 21 hours 14 minutes 27 seconds ago) was attempting some stupid hack to get steam overlay on origin games.
    – user114790
    Nov 3, 2016 at 21:36

You must log in to answer this question.