2

Spoiler warning for Technobabylon chapter 3. Requesting if at all possible that answers and comments are as spoiler-free as possible for anywhere beyond the situation described.

So I've reached chapter 3 in the new Wadjet Eye adventure Technobabylon, the scene in the apartment of Giel van der Waal. I need to unlock his terminal to get details on the frozen synth. The terminal has two required unlocks: the password which is easy to guess, and the biometric.

I'm encountering what seems like a glitch when trying to use his severed hand (eww) to unlock the biometric. I've got the cooking gel out of the cupboard and applied it to the hand: this produces the promising comment "the hand becomes noticeably warmer". However, it still doesn't unlock the biometric; the right-click comment still says "Giel van der Waal's cold, dead hand"; and the cooking gel gives no right-click description comment, and repeating the operation of combining the gel and the hand gives no comment whatsoever. I wondered if I was just missing some other step to do to the hand, but Lao's hint on the topic suggests we need to warm up the hand, or possibly give it a pulse. I can't use the Jolt Gun or any other inventory items to make it twitch, I can't get the food machine to warm it up, and I can't use the gel on the terminal screen directly.

I'm nervous to Google too much about this because I'd really rather avoid spoilers if at all possible (though I've seen no relevant hits for "Technobabylon glitch"; but it is a very new game).

So my questions are:

  1. Am I just missing some further interaction I need to do, beyond applying thermal gel to the hand? If so then a simple "Yes" along with perhaps a small or vague hint would be great.
  2. If not, and it is meant to work applying the gel to the hand then the hand to the terminal, does anyone know a way to avoid the bug? I've tried relating from before I opened the apartment door and got the same result.

2 Answers 2

3

click right on the gel to set his temperature.

2

Thanks to renéone. I've confirmed that yes, there is a glitch here.

What you need to do is, after picking up the cooking gel, right-click on it to bring up a separate screen to set its temperature. You must do this before using the gel on the hand, otherwise the game gets into a bad state and is unwinnable.

4
  • It was not unwinnable for me but the temperature required is very specific and possibly only works after sizzling the hand at least once.
    – rjh
    Commented Apr 1, 2022 at 8:34
  • @rjh: If you get the temperature set screen, you've avoided the glitch. If you use gel on the hand before opening the temperature set screen, then (we found) that the interface does not appear so there's no way to set the temperature and thus progress in the game.
    – AlexC
    Commented Apr 1, 2022 at 15:25
  • I used the gel on the hand before right-clicking it and there was no bug, so either the glitch is random or it's been fixed :)
    – rjh
    Commented Apr 1, 2022 at 22:13
  • Hopefully it's been fixed!
    – AlexC
    Commented Apr 2, 2022 at 11:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .