In Witcher 3 I'm at what seems to be a dead end. After Radovid told his men to kill Geralt, I pursued him and he is now in a fenced area, alone. My objective: kill Radovid.

Alas, there is no way to get into this fenced area. All I managed in 15 minutes of trying was to get on top of the fence, but I cannot cross to the other side.

What am I missing? What am I supposed to do? How can I get to Radovid from there?

NB: I also tried Aard and Igni in the hope to destroy the fence.

3 Answers 3


I have also found this a little bit counterintuitive, but - in order to progress you need to kill everyone in the group that attacks you right after Radovids order. You'll know that you're done thanks to cutscene with Roche who, along with a few people, join you in this hunt.

That part is easy to miss thanks to one soldier of said group spawning right at the edge of the area, at the far end of a narrow street making him completely harmless and missable.

Actual Radovid killing will also happen in a cutscene, firing right after you get there with Roche, so the fence being indestructible and uncircumventable is by design.

  • Thanks for the hint. I guess then I have another problem altogether. Turns out there is a Redanian soldier left over on the other side of the bridge (where the fast travel waypoint is). But the guy isn't aggressive towards me. I have to provoke him to be able to kill him. Worse yet, when I go to Roche (traversing all streets, looking for other Redanians) I still can't cross. So I go back to the other side of the bridge and there the soldier is once again, despite having been killed before. Will try to upgrade from 1.04 to 1.05 and reload a previous savegame. Btw: I had the cut scene. Jun 13, 2015 at 19:55
  • accepting your answer. Thanks. It turns out there was an additional issue so I answered as well just to make sure that, should anybody else run into this, they'll be able to find a solution. Jun 13, 2015 at 20:47

Deltharis was mostly right, although it took me some time to understand the exact meaning. I'll accept his answer, but want to outline what seems to have happened. I tried this both with patch 1.04 and 1.05 - this particular thing is clearly not addressed by the patch.

I loaded an older savegame right at the point when the Redanians attack Geralt by the king's order.

Problem is that at the blockade there is a Redanian soldier that is not aggressive towards Geralt until you provoke him. It's the same soldier that I couldn't kill after the cutscene in which Roche joins Geralt after the king gave the order and Geralt fought off the first enemies.

If you manage to kill that Redanian soldier before the cutscene with Roche, you simply proceed crossing the bridge. At the other end, and after killing all enemies in the way (there are none in the smaller streets), you will see another cutscene, which allows to progress further in the quest.

There is one thing that I only noticed after retrying as described above. The first time around, when I didn't get the second cutscene at the temple isle end of the bridge, there were witch hunters standing around idly along with Roche, Ves and Geralt. Those didn't stand around anymore when I got it right - they had to be fought on the way to the king.


I know its late but if anyone new is experiencing this reload the last save, youre glitched. Happened to me.

  • 3
    According to the accepted answer that's not the case. Can you expand on your answer?
    – Joachim
    Jun 5, 2021 at 9:24
  • @Joachim I mainly accepted the answer from someone else because 1. it was helpful and 2. I had nothing to gain from accepting my own answer. But the full picture can only be seen from reading both answers, really. Jun 6, 2021 at 20:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .