I recently downloaded LoL and I've had some issues on the "step 2/2 updating league of legends" causing me to (still) not being able to get in. The KBPS keeps dropping to 0 and won't go back up, even after hours. I've looked around the Internet, but nothing seems to work.

  • Are you Mac or PC? – Charkz Jun 16 '15 at 13:13
  • It's a lenovo 😊 – user23448 Jun 16 '15 at 13:14
  • 1
    Okay, normally, when this problem happens it continues after a short while sometimes after 30min. Try running it as Administrator and make sure your firewall isn't blocking the launcher. – Charkz Jun 16 '15 at 13:15
  • Actually I tried to turn off the firewall while finishing but it still doesn't work. Also I let it run all day while I was in school. Still won't pick up -_- – user23448 Jun 16 '15 at 13:17
  • I've experienced the same issue. I've waited 10 hours during the working day but no change. After a clean reinstall everything worked fine for me. – Ionic Jun 16 '15 at 13:24

A lot of these are going to be super simple, but may as well try 'em. They're in the order I reccomend doing them in. Note that you can do many at the same time.:

  • Are you installing from the same file each time? If so, download a new installer.
  • Restart your PC
  • Run installer as Admin
  • Enable / Disable P2P: In your client, click the gear icon in the top-right, and then check or uncheck "Enable Peer to Peer Transfer":

Enabling or Disabling P2P

  • Close out all other unneeded programs -- like, all of them
  • I don't know how you're uninstalling League, but try doing it with a free trial of Revo Uninstaller. Then reinstall.
  • Contact League support

Again, you have probably tried many of these already; sorry if this answer is redudant.

|improve this answer|||||
  • To be honest I got it downloaded on my new computer. But then I bumped into a new problem - when I click "launch" the game closes down and nothing happens – user23448 Jun 26 '15 at 8:46
  • Huh. Try redownloading without P2P and with Admin rights. If that doesn't work, ask League support. – Quelklef Jun 26 '15 at 20:28
  • The P2P hasn't affected it at all... 😐 neither did admin. Guess I'll see if I can get in contact with league support – user23448 Jun 26 '15 at 20:34
  • OK, good luck :] – Quelklef Jun 26 '15 at 20:38
  • I'm trying to figure out what this problem is, but I can't see anything like this on their support side. Thanks for your help tho 😊 – user23448 Jun 26 '15 at 20:40

Try putting it in Low Spec Mode. Only way I could get it to download.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.