0

I have a TH8 base and it's connected with Google+. I had to reset my phone a few days ago because it was giving me problems. After I reset my phone I logged into Google+ and installed the game, but it won't load!

I have tried every possible thing, I updated the game and Google+ app and Google play games...everything.. but still could not recover my village...

What can I do?

  • 1
    As usual, email SuperCell – Ben Craig Jun 16 '15 at 22:03
  • Not responding... – Kelzang Dorji Jun 16 '15 at 22:09
  • Any other suggestion @Ben Craig? – Kelzang Dorji Jun 16 '15 at 22:10
-1

I am sure you might have done this, yet just a shot at it might help:

Google games is the app through which we are connected to COC. Remove that from your phone. Install it again and use your correct gmail id to log in.

Just for surety , just check the settings part in COC and see if Google play is connected.

Hope it helps.

| improve this answer | |
-1

http://www.androidapksfree.com/apk/google-play-games-3-4-12-2379351-038-android-apk-download/

Click on the link and install version of 3.4.12 google play. Then go to your mobile settings->app manager, and change the settings of google play services to uninstall the update. Then it will work. I had the same problem.

| improve this answer | |
-1

Try my method it should work.

  1. Get the latest google play games app (older version should also work)
  2. Open the app
  3. Sign in to your google account
  4. Go to setting
  5. Under setting, enable Sign in to games automatically.

Done! problem solved! I hope this help you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.