3

I'm trying to make an RPG adventure where the player can interact with different stuff. For example, if he walks up to a crafting table, then this text should come up in chat:

[Robert:] I wish there was a Crafting Guide in Minecraft or something, it's always so hard to remember what some of the crafting recipes are!

The crafting table works fine, I have a hopper clock connected to a redstone which has a repeater going into a command blocks saying:

/testfor @a[6,80,3,1]

Connected to a comparator connected to a command block saying

/tellraw @p ["",{"text":"[Robert:] ","color":"dark_blue"},{"text":"I wish they had a crafting guide in Minecraft or something, it's always so hard to remember what some of the crafting recipies are!","color":"white"}]

This works fine. When I walk up to the crafting table, it works. But when I walk up to the ladder, well that's a different story.

In my "Ladder Interaction" section of the redstone, I have the same hopper clock, with the same item, connecting to the comparator in the same way, with the redstone to the repeater, connected to this command block:

/testfor @a[-20,84,7,3]

Connected to a comparator which is then connected to:

/tellraw @p ["",{"text":"[Robert:] ","color":"dark_blue"},{"text":"Uh-Oh! The lava must've burned some of the ladders, so I need another ladder in order to get up. Come on! Better find one quickly!","color":"white"}]

I don't understand why this one won't work but the other does. I changed my redstone clock to a hopper clock, like I said, because people said that it keeps the chunks loaded and stuff, but it still doesn't work.

Here's a picture of my design: My basic interaction design

Can you help me?

4
  • 1
    Verify that the repeater is turning on and off, and that the command block is not being powered from elsewhere. Also make sure that you are actually within a radius of 3 from -20, 84, 7. The commands you have given work fine, so your problem is likely being caused by another factor.
    – SirBenet
    Commented Jun 20, 2015 at 1:04
  • I have done all that and it still doesn't work! Commented Jun 20, 2015 at 1:06
  • Does the command block output any errors?
    – user114997
    Commented Jan 22, 2016 at 21:23
  • No it just acts like it was never activated Commented Jan 23, 2016 at 19:05

1 Answer 1

1

There is this one character (I don't know what it is yet, either), that sometimes, somehow, makes its way into commands. Try going to the beginning of your /testfor command, and holding -> until you reach the end. There may be a spot where your cursor stops moving, and there should be a zero-width invisible character there. It shows up in regular editing software, I always check if my commands aren't working.

1
  • I'm pretty sure it's the NULL character.
    – b44ken
    Commented Apr 28, 2016 at 23:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .