3

I have a problem with my server. I own a server with Spigot 1.8.3, Multiverse (idk the version) and PlotMe. (Essentials RELOADED vTeamCity) I'm using McMyAdmin. I get chunks error. Sometimes, chunks aren't generating and I need to disconnect/reconnect or restart the server to fix the problem. I got a "freezed" chunk in the spawn. Pressure plates aren't working (/clone and /fill are working). When I spawn mobs, they are frozen.

Here is a screenshot of the issue: enter image description here enter image description here

I am trying to repair chunks ("it says no chunk error") In MCEDIT, the chunk is showing. I can place or break blocks. Levers and buttons are working.

sorry for bad english, im french EDIT : I'm playing on Minecraft 1.8.1. With 1.8 and optifine it's working great. This is a client issue

  • And when I do //butcher or /killall all, mobs stays. EDIT : 5 minutes later, they dispear. But the chunk is not fixed. – NathaanGaming Jun 21 '15 at 16:43
  • could it be lag? – Universal Electricity Jun 21 '15 at 16:59
  • 2
    Server lag probably – nelson2tm Jun 22 '15 at 6:03
  • The chunk is fixed but I got glitched chunks in another world... – NathaanGaming Jun 30 '15 at 15:01
  • Do you have a host for your server or are you hosting yourself? – Jason_ Mar 9 '16 at 17:33
3
+75

There are certain ways you can attempt to fix a chunk error:

For server use:

Added Edit:

Source

It could be that your TPS is set low. TPS is much like FPS but for the server. It cannot go above 20, and it should stay at 20. TPS stands for Ticks Per Second. This applies to singleplayer, as it runs a sort of local server when you load one, this is to allow opening to LAN.

Common symptoms of low TPS include the sky jumping back a little bit every second making it look laggy and extending length of day/night cycle, mobs/entities (not including players) moving unusually slowly, all entities that can take damage take it much more slowly with delay, all entities effected by gravity falling slowly in choppy little bits, players seemingly teleporting around in multiplayer (purely visual), blocks difficult to place/destroy (multiplayer and in extreme cases in singleplayer), etc.

Check your game's Ticks Per Second by typing /gamerule randomTickSpeed If the speed is set to larger then 3 then we may have found your problem. Set it back to 3 if it is set higher.


With a little research I think WorldBoarder may solve your problem it allows you to fully generate (fill) your world all the way to the border, filling in any missing chunks, including a configurable buffer zone just outside your border.

With a little help you can also make another possibility possible. If you were to create another account and keep that account in the needed chunks then it is possible that the chunks won't unload keeping them fully functional. I Found a great video that could go hand in hand with this idea: Super Chunk loader

If this is the most important part in your world that isn't loaded, you could place it in your spawn chunks. Spawn chunks stay loaded in your world because they are stored in your memory.

You could also use the commonly talked about hopper chunk loader which may keep the chunk loaded all the time. Hopper Chunk loader As an edit to your comment on how loadding your whole map would be an inconvenience, I found another Chunk loader that can be set to load only one chunk: Here is the link: Minecraft 1.8.8 Remote Chunk Loader Explained

It is possible and could be likely that you have a corrupted chunk even if it says you don't. There are different types of corrupted chunks, but there are ways to patch, fix, and delete depending on the problem. This would require MCedit to fix. I would suggest copying this part of your world with commands or Woldedit before you try this, if you still can. If you close your server for a bit and load it up in single player, you can attempt to patch it using this method: Corrupted chunk fix for single player You may need a similar fix like this, but not this one, so this will only get you to the starting line and help in your search.

As a final thing I found a mod that may do what you want. It is called CodeChickenCore. In this mod it has something called ChickenChunks, This is what it should include: This introduces a new block called the “Chunk Loader”, which allows chunks to be loaded in memory at all times. It is very convenient to use as it comes with a special GUI for configuring chunk loading. Chunks are also free to load.

I found this download here.

  • Reloading the chunks would be a pain for alot of players, and a staff member would have to tell people to do it every time there is a problem. We are a factions server, we have a good amount of RAM (8 GB) but to load a 30x30K map, would be way too much. – 09stephenb Mar 10 '16 at 21:13
  • I'll try more brainstorming. – Jason_ Mar 10 '16 at 21:27
  • NathaanGaming and @09stephenb, any feedback on what you try to see if this works would be great so I can help fix the problem! – Jason_ Mar 14 '16 at 4:38
  • the problem is pretty much as described in the question. Only difference being, that we are a factions server, and is it is creepers, (and all other mobs) getting stuck. I can place a creeper light it with a flint and steel, but then it will swell up, and the second before it is ment to explode it's frozen. Can't be damaged can be moved, or stuck. Since creeper eggs are quite expensive, players arnt happy, when the occurs. – 09stephenb Mar 14 '16 at 10:01
  • @09stephenb try checking your TPS. In my edit. – Jason_ Mar 14 '16 at 23:47
1

For the ones they got the problem. If you are using Multiverse, just unload/reload the world, it can fix your problem (IT CAN, MAYBE WORKING MAYBE NOT)

With MCEdit, try the chunk repair too or play the map in single player for check if it's your map of the server.

the end

  • The server has a decent player base, and unloading the whole world, would cause problems for a number of players. – 09stephenb Mar 10 '16 at 21:09
  • If this is how you solved the issue, you can click the check mark next to your answer to tell others that you've solved the problem. – rivermont - Will B. Mar 16 '16 at 17:28
  • @rivermont-WillB. I would but this doesn’t solve the problem, its just a work around, not really a solution. The problem will keep coming back. – 09stephenb Mar 16 '16 at 23:27
1

You use 1.8.1 and probably Spigot to run those plugins you mentioned.

Spigot is known as kind of unstable project with a lot of bugged versions. You might have one of those, because I seen similar problems with people using it (especially not working AI of mobs etc)

However as Spigot is unstable, it also has constant development, so a lot of bugs were fixed already.

You should update your server to latest 1.8 version, like 1.8.8 or 1.8.9, with possibly latest server version as well. You will be able to connect with same 1.8.1 version client, however I would use at least higher version than 1.8.3 (bugs with special characters etc). AFAIK the version 1.8.9 is stable with Forge and OptiFine so you can use this version for client as well.

(I doubt it that it is pure client problem, however if it is, then you should do the same - update the client to latest 1.8 version.)

For doing so all you need to alter is the main server.jar file (do it when server is stopped!), nothing else is needed to alter and should be fine.

  • We are running a 1.8.8 version of spigot, i have tried changing to a diffrent 1.8 build, but still no luck. – 09stephenb Mar 10 '16 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.