2

I'm currently have this problem with the modding in Civilization 5 without anything only the basic game.In the steam workshop I find the mods that I want but it says "You need DLC to use this item." What does that mean?

  • 1
    more than likely the mod is using content from DLC, as such because you don't have the DLC the resources the mod is going to use are missing. the fact it knows your missing DLC probably means the mod itself lists what DLC you need installed as a requirement – Memor-X Jun 22 '15 at 4:05
  • Same thin with Civ 6 – Mawg Jun 9 at 10:52
3

It means that you need to own either or both of the Civ 5 expansion packs, Brave New World // Gods and Kings, in order to use that mod. This suggests that the mod either uses assets or mechanics from the expansions, and by not owning them, you can't support that mod.

You can see in the screenshot below that this mod is tagged with Brave New World - that means it requires that expansion to play. When browsing mods, simply avoid any with the Brave New World or Gods and Kings tags, and you should be able to find some to play.

showing mod tag

  • How would that be with Civ 6? What's the cheapest way to install a mod that I want (by buying a cheap expansion that I don't want)? – Mawg Jun 9 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.