1

I've been playing "Marvel Contest of Champions" pretty religiously for the past month-and-a-half and really enjoying the game. Two weeks ago I spent $19.99 to buy some units so that I can then buy some crystals in the hopes of getting some 3-star or 4-star heroes. The purchase went 100% as expected, I bought my crystals, got a few heroes to make my team stronger, and the world kept turning.

Today, however, I attempted to buy some units again, and now the "Units Store" is completely blank aside from the header. Below are some screenshots --

Main Menu:

Main Menu

Units Store:

Units Store

I have no idea why I can't actually view any of the buying options for credits anymore, but I can't find anything on the web regarding this issue. Nobody seems to having the same problem I am. Has anyone seen anything similar at all?

I'm playing the game on an iPhone 6 Plus (64GB), iOS 8.1.3, and the Contest of Champions app is completely up-to-date.

My phone is jailbroken, but it was jailbroken a few weeks ago when I bought those credits as well, and I've changed nothing about the phone since. I don't even think I've updated the app since then (because there hasn't been one available), so I don't have a clue what's changed.

Does anyone have any idea why this could be happening? I'd be very grateful if you would share.

  • Hi Mike, I've added the tag for you, and inlined the images :). Have you tried force-killing & restarting the app, restarting your phone, or even (as a last resort) reinstalling the app? It's potentially gotten itself into some cached state where it isn't showing anything, and those may be the easiest ways to solve it. – Robotnik Aug 5 '15 at 8:01
  • Thanks for your time and assistance, @Robotnik ! -- I updated the app a few weeks back, and the units store now displays roughly 50% of the time. I've tried force-killing and restarting, installing and reinstalling, etc... I've even restored iOS from a backup, to remove the jailbreak in the hopes that any issues I'd seen (in this app & various others) were JB-related & would be remedied using stock iOS. Some things were fixed, some were not. At this point, I believe the issue w/MCC is server-side, and that perhaps Marvel needs to contact their developer to remedy the problem. Thanks again! – MikeMitchell Aug 5 '15 at 19:31
-1

They do it to stop hackers. It's a basic firewall. You can delete it by connecting your phone to a PC. Also, you can edit your units and gold etc. by cut and pasting files.

This worked for me on Android. This should work on iOS.

  • This doesn't explain what the user is seeing. They have a blank white box, and you say it's a firewall? – djsmiley2k - CoW Jul 29 '15 at 17:06
  • while I do not think this solves the problem, in my experience iOS does not allow direct access like an android phone. Most of its PC Xfer operates through iTunes for this reason. So I doubt the answer would apply to iOS as it does to Android. – user106385 Jul 29 '15 at 17:08
  • Delete what exactly? What's the file that should be deleted? – Robotnik Aug 5 '15 at 8:02
  • I was told by someone on the app's forums that the app performs an integrity check on startup to ensure that the numeric value of units (and other consumables, currencies, etc...) in the .plist file stored locally on the device matches the value that the server has stored in the cloud. If the integrity check fails (for any reason, not necessarily related to hacking that file) the app will either crash, or (as in my case) the ability to make in-app purchases is disabled. If a network error occurs during the integrity check, this could cause the IAP issues I saw. I no longer use the app. Thanks! – MikeMitchell Aug 5 '15 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.