2

I want to play C&C:KW but the game simply does not start.

I have read a couple of forums and it seems there are a lot of problems with the game on windows 8.

My Specifications:

  • Window 8.1
  • Lenovo S540
  • i5-4210U
  • 8 GB RAM
  • 250 GB SSD
  • Intel HD graphics
  • AMD Radeon HD 8670M

This is what happens when I try to run the game: enter image description here

What I already tried:

  1. turn off Origin in game
  2. Installing older DirectX version
  3. Run the game in Windows Vista, 7 and xp compatibility mode
  4. Use start parameters: -xres 1080 -yres 1920

All with no success

6
  • 1
    You could try some other compatibility modes?
    – Nyerguds
    Jun 28 '15 at 22:30
  • I tried Windows xp Jun 30 '15 at 14:29
  • A couple of threads about this issue on answers.ea.com showed it could be due to a recent update to the Intel HD Graphics drivers... Not sure if that helps.
    – Nyerguds
    Jul 1 '15 at 9:07
  • Apparently, on NVidia, there's a 'preferred graphics processor' setting to change to "high-performance" that apparently makes sure it doesn't use the intel HD GPU but the video card's. Maybe you should find some similar setting for your AMD card?
    – Nyerguds
    Jul 1 '15 at 9:13
  • I have not found any option to force use my AMD Radeon. I've looked for this for a time and found no way to do it. BTW the AMD Radeon card sucks next time I buy a laptop with an NVidia card. Jul 1 '15 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.