0

I bought FFXIV from flipkart(http://www.flipkart.com/realm.../p/itmdmnw5gjwy2jzw...), registered my product on PSN using the code which came with it but still can't play the game. All the information provided on the squire-enix site seems to be useless, I've tried everything but can't make this OTP thing work even after installing the software token from play store(https://play.google.com/store/apps/details...). It asks for a registration password which I'm not aware of. My game is already registered as shown in the screenshot below. enter image description here enter image description here

I contacted them through the e-mail, their fb page, and they do not care to respond

6
  • When did you try to contact the support?
    – Nitro.de
    Jun 29, 2015 at 6:39
  • number of times, first contacted a week ago Jun 29, 2015 at 6:40
  • You've to edit your question, half of the links dont work
    – Nitro.de
    Jun 29, 2015 at 6:41
  • which one is not working? all are working for me.. anyways added the screenshots and removed the links Jun 29, 2015 at 6:42
  • flipkart is not working neither google.. and you should delete or edit the first picture because your email and birthday is visible
    – Nitro.de
    Jun 29, 2015 at 6:58

1 Answer 1

1

Try live chat with their support. I had problems in removing my token because I lost it and I do a live chat with their support and my issue got solved.

Take note of their operating hour and its timezone.

1
  • done.. after I was able to login it asked me to update, which was more than 1 GB, so I thought I'd rather than play it. stupid game! Jul 27, 2015 at 8:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .