13

So The Witcher 3 has been crashing constantly ever since I started playing it and I'm having a hard time diagnosing it. I've still played it a fair bit but now I'm at my wits end (playing 10 minutes before a crash is considered good, often it'll crash while loading). I'm pretty sure it's some faulty hardware of mine but I'm not sure to start.

Typically I'll either get an actual error (APPCRASH) or it'll just boot me to desktop with no errors. It can crash at any point (while moving, while playing gwent, while loading and while doing just about nothing).

An APPCRASH always looks like this:

  Problem Event Name:   APPCRASH
  Application Name: witcher3.exe
  Application Version:  3.0.4.58000
  Application Timestamp:    5579b8b9
  Fault Module Name:    witcher3.exe
  Fault Module Version: 3.0.4.58000
  Fault Module Timestamp:   5579b8b9
  Exception Code:   c00000fd
  Exception Offset: 0000000000e0f117
  OS Version:   6.1.7600.2.0.0.256.48
  Locale ID:    1033
  Additional Information 1: 755c
  Additional Information 2: 755c2ef5ca0cfe56d868b4b01f50b3be
  Additional Information 3: f44e
  Additional Information 4: f44ecf6ab3842bb0e5d8de5a0f380bfc

What I've tried:

  • Reinstalling the game.
  • Installing the game on another hardrive.
  • Updating graphics card drivers.
  • Messing around with in-game settings (fps limit, hair works, fullscreen/windowed, lowest graphics, highest graphics, resolution etc).
  • Installing via gog galaxy and stand-alone.
  • I just formated my entire computer and reinstalled windows and it still crashed within 3 minutes of starting a new game, so I'm pretty sure some hardware is at fault.
  • I recently also played through x-com again and this would also crash (but very rarely in comparison to the witcher 3).

I ran memtest a while back and it turned up with no errors. My graphics card is brand new (and I had crashes before I switched it out as well) so I don't /think/ it's responsible but it could be. Considering I've installed it on different HDD's I don't think it's a drive fault either. This leaves either the PSU, the motherboard or the CPU. I ran a CPU test the other day (hot CPU tester, not sure if that's any good or if someone can recommend some other software) and after 6 hours of testing it informed me it found a faulty checksum in some of its calculations, so I'm thinking the CPU could be at fault.

I honestly have no clue how to properly test my motherboard or PSU. Any hints on this would be greatly appreciated because at this point I just can't be bothered playing anything at all.

  • 2
    +1 for telling us what you've tried so far. Can you list your hardware specs? CPU, GPU, RAM, etc? If you don't know how to easily identify these, an app called CPU-Z can help you collect those. – user973 Jun 30 '15 at 20:38
  • 2
    Sure thing. Intel I7-2600K CPU processor, GTX 970 graphics card, P8Z68-V PRO motherboard, CORSAIR HX 750W PSU, 16GB COSRAIR DDR3 VENGEANCE ram (1600 MHZ) – user3932479 Jun 30 '15 at 21:06
  • I've had the same problem and it was caused by the driver of my GTX 970, you might want to look at it: Witcher 2 crashes every few minutes – Lunaetic Jul 1 '15 at 7:25
  • Windows 8.1? Anyway, check out this thread: gaming.stackexchange.com/questions/222756/… – DrFish Jul 1 '15 at 12:04
  • Are you over clocking your graphics card? I ran into a lot of issues with that game crashing when I was over clocking my gpu. Turned off the over clock and it ran perfect. – Dupree3 Jul 1 '15 at 18:34
1

I can see why there are several posts suspecting it might be your video card overheating... the behavior you describe kind of suggests it... but it might be power settings.

Check the 'Manage 3D Settings' category in the NVIDIA Control Panel and make sure your Power Management Mode is set to Optimal Power. This is the default setting, so its kind of a long shot, but when it comes to troubleshooting, you need to be thorough.

With that 'thorough' concept in mind, test the stability during game play. If you can, find a large group of wolves or nekkers or something... try to cause graphic intensive activity. If it really is overheating, the GPU fan should cause a noticeable sound difference, not to mention the game would crash soon after. This serves the purpose of eliminating the cause more than it attempts to resolve the issue, but if you have overheating hardware, it needs to be addressed immediately.

Here's a final suggestion should your issue persist. Find the game installation folder... which, I think, by default is

C:\Program Files(x86)\The Witcher 3 Wild Hunt

and navigate to the bin\config\base folder. Now locate the rendering.ini file and create a copy somewhere... anywhere.

Once you have the file backed up, Right-Click and Edit it. Either use the search function or skim the variables (under the [Rendering] block) until you spot TextureMemoryBudget=500 and increase this to 1024. Save the file, and test out the game again.

Hope this helps. If not, I think the error information needs to be analyzed a little more closely... in an attempt to narrow down and pinpoint a more precise cause.

0

Try to "underclock" your GTX 970 with a tool like Nvidia Inspector. You can start with -50Mhz for Base Clock Offset and -200Mhz for Memory Clock Offset. If this would run stable, you can increase the values until Witcher 3 crashes again.

  • I tried this but it's still crashing at -50Mhz for base and -200Mhz for memory clock. It did seem like it's taking longer to crash though but it's difficult to say, I'll run with this some more and see. – user3932479 Jul 1 '15 at 19:00
  • You can try it with higher values, like -100Mhz and -400Mhz just to check if this really helps. – PeterCo Jul 2 '15 at 7:53
0

I went through a similar problem.

What I did was turn off the Steam Cloud and in the game made a new save, then deleted all the others. I think some were corrupt.

0
  1. Turn off in-game V-Sync and use Nvidia Adaptive V-Sync/ Dynamic V-Sync for AMD.

  2. Uncap the Framerate. Set "Maximum Frames Per Second" to "Unlimited." There is no need to limit our framerate and let GPU/CPU power go unused.

  3. Set the Display Mode to "Full Screen" and not on "Borderless Window."

These three simple tweaks can improve the overall stability and make the game more responsive. If you want to use V-Sync, I recommend using Nvidia's Adaptive V-Sync for Nvidia users or Dynamic V-Sync for AMD users (by using Radeon Pro).

  • Can you embed the link in your answer? Just putting levelskip.com doesn't really help anyone who wants to go to the page and look at it for themselves. – Kyle Rone Feb 14 '18 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.