4

So, I have a legal full version of Minecraft, version 1.8.7, running Windows XP SP2, whenever I try to connect to a server, it does not connect.

When connecting to Hypixel, I get:

Connection Lost Internal Exception: java.lang.IllegalArgumentException: Parameter ´directory´ is not a directory

On RebornCraft, I get:

Connection Lost Disconnected

I know that my firewall is not the issue as I have played on these same servers previously. I tried typing in the server address again with no luck.

Also, my server ping is perfect: Server ping is perfect and yet I can't connect...

Images showing the issue (Full size: 1, 2):
Random java error Disconnected

3
  • 1
    I found a bugtracker entry with the same error as the one you got at Hypixel: MC-81082. Although it is marked as "fixed", try the workaround: Create a folder called server-resource-packs in your .minecraft folder and try again. – MrLemon Jul 1 '15 at 16:14
  • If the above does not work, backup your saves and whatever else you deem important (resourcepacks, modded versions, etc.) and delete the entire .minecraft folder to force a reinstall of the game. – MrLemon Jul 1 '15 at 16:17
  • Unfortunately, neither of those worked. I did exactly what you said but they failed. – user117156 Jul 3 '15 at 17:19
1

Manually create the directory .minecraft/server-resource-packs, to fix And, the

Connection Lost
Disconnected

is just a small bug. Reinstalling Minecraft Should do the trick.

2
  • I fixed it, it was just the auto login bug... – user117156 Aug 4 '15 at 18:09
  • Well, alright! I'm glad you got the problem fixed. – Joseph Christian Hefley Aug 5 '15 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy