2

I bought into the Gun Mettle campaign.

My HUD says I have 2 “inactive” contracts. I'm already on the class and map specified in them. Clicking on them gives me objectives and a misformatted tooltip:

(Contracts drawer)

(Tooltip with only the letters "T" and "C")

Does them being “inactive” mean I have to activate them? If so, how do I do that?

If not, why aren't they active — is there some other condition I'm not meeting?

  • I think you can press f2 in game, and click on an inactive contract, and it will say at the bottom why it's inactive. – Kyranstar Jul 3 '15 at 3:34
  • @Kyranstar The text at the bottom end of the contract seems to be only flavor. The tooltip (which I suspect is what you're referring to) is illegible. An answer listing the possible reasons for inactivity would be helpful! – Kevin Reid Jul 3 '15 at 3:38
3

There are two reasons I know of for a contract not being active. One is you are the wrong class for the contract the other is you are not on a Valve server. The easiest way to join a Valve server is to use the quick play feature and select gun mettle.

Many 3rd party servers are displaying gun mettle in their servername now but contracts will not work on them, they will just be hosting the new maps etc...

If you hover over the contract it will also give you the reasons for the contract not being active via a tooltip.

enter image description here

  • There is no text like that on the bottom of my contract. See the screenshots in my question. – Kevin Reid Jul 3 '15 at 15:17
  • I know which means you have encountered a bug. There are sometimes UI scaling issues on TF2 what resolution are you running. Regardless I believe I have made clear how to get contracts working. – kenjara Jul 3 '15 at 15:19
  • Ok I was wrong that information is in the tooltip which you can not see as yours is messed up. – kenjara Jul 3 '15 at 15:56
1

Are you playing on a Valve server? Meaning one you accessed through Quick-Play. If you are not, the contracts are invalidated (I suppose to stop farming maps).

  • This does seem plausible, but I've played on Valve servers and it still says inactive. – Kevin Reid Jul 3 '15 at 15:17
  • ...and it worked the second time I tried today. Guess it's just glitchy. – Kevin Reid Jul 3 '15 at 15:42
0

I tried joining a Valve server and choosing the proper class again. The second time today, it worked. Guess it's just glitchy.

protected by Community Jul 5 '15 at 22:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.