I've nearly reached the breaking point with this game. A few more failed startups and my fist will be through my monitor.

I've tried everything on the Internet. I've gone through four Google pages worth of links, trying everything mentioned. I simply cannot reach a solution. I have an options.ini, but my game will not start. When I put in a specific resolution, I get the DirectX 8.0c error, but it goes away when I use any other resolution. I tried the solutions for the DirectX issue, but nothing worked. Now when I start the game, I get:

enter image description here

It just opens, pauses for a second, makes my screen go black for a second (just to give me hope, I presume), goes back to what you see above, then sends the splash image to the top left, then closes. The game does not open, it just closes.

At this point I'm just done. I can't find the solution myself. Does anyone know how to fix this?

  • have you run it in compatibility mode?
    – user106385
    Jul 9, 2015 at 0:05
  • 3
    @Timelord64 XP SP 2 and 3, Vista, and 7. All do nothing.
    – Zulfe
    Jul 9, 2015 at 0:38
  • I would be keeping it toggled for XP SP3, though. XP is the last version on its system requirements. I am assuming this is the guide you originally followed gamereplays.org/community/index.php?showtopic=807601 Please confirm that you have deleted the original save data, restarted the computer, and run in Service Pack 3 Compatibility WITH Administration user toggled. This will help other people cross off the basics when answering your question.
    – user106385
    Jul 9, 2015 at 0:48
  • Try running in Windowed mode.
    – L4NC3RJ
    Jul 10, 2015 at 5:12
  • 4
    Possible duplicate of How can I run C&C Generals Zero Hour on Windows 7
    – pppery
    May 29, 2023 at 16:20

2 Answers 2


Well, this might be caused by something i've experienced just recently.

Solution: Reinstall your game.


  • You've had at least one previous successful startup on that machine at all.
  • The game files were recently edited in ANY WAY; this includes updates from Origin!

So, turns out, it might be an issue with the game engine being unable to properly detect DirectX on your system. This is most likely because of corruption in the game engine code that is used to verify the version of DirectX that you are using (which can be caused by a multitude of things, such as game updates or mods). Usually some symptoms of this is when you Alt+Tab, hover over the game icon in the taskbar, and seeing 2 windows: one which is most likely an error message that states that you need DirectX 7.0 or higher.

If your conditions match those above, you should be able to reinstall the game without any issues. Your save games may be recovered upon the successful install of the new copy of the game because of Origin cloud backups. HOWEVER, do not purely rely on this system to keep your saved game safe and sound; always remember to periodically backup your saved games folder in the game files manually.

  • While games from The First Decade and earlier releases tends to break on Win7+, Ultimate Collection re-release works fine without any tweaks. It can be used as 10 bucks fix.
    – PTwr
    Mar 10, 2017 at 9:33
  • @PTwr Yeah, I agree. I currently own a [physical] copy of The First Decade, and I have had more issues on that distribution compared to my copy of Ultimate Collection on Origin. In fact, on my First Decade copy, Generals would run without any issues, but Zero Hour wouldn't even get past the splash screen intro before it decided to quit. Compatibility Mode didn't help, so I just decided to dump it for good. Mar 10, 2017 at 17:57

right click generals.exe and click Test Compatibility. I successfully played this game in Windows 8 in full resolution.Make sure you are able to save settings after the computer test the game for compatibility.

Not the answer you're looking for? Browse other questions tagged .