4

Realize that this game is a bit older, but I'm hoping to play with some friends online!

Whenever I try to host or get invited to a multiplayer game my whole steam client crashes. The game either dumps me to the desktop or freezes and I have to terminate it via task manager. From time to time the game will load into the starting zone and then freeze, telling the other player that I have disconnected.

Single player works great.

What I have tried so far to resolve this:

  • Reboot the system after the initial problem
  • Verify integrity of game files locally (no problems)
  • Update video card drivers
  • Reinstall the steam client while preserving the steamapps folders
  • Reinstall the game via the steam client (uninstall then install)
  • Run steam as administrator
  • Run Borderlands directly as administrator
  • Run Borderlands EXE in Windows XP service pack 2 compatibility mode (this disabled "Online Game" option - was not helpful)
  • Added inbound and outbound blanket allow rules for the borderlands.exe and steam.exe executables in Windows Firewall advanced settings.

Additional troubleshooting info:

  • Running Windows 7
  • Core i5 4670k / GTX 660ti / 16GB RAM
  • A Wireshark packet capture at the time of the crash indicates no unusual traffic between the steam servers and my system.
  • Events manager registers no application or system errors when steam crashes
  • Steam does not throw any error messages when it crashes, it simply closes in the background
  • I have no idea what to make of the dump files; I assume these are the memory states when the application crashed. They correlate with the time of each crash, but I am not an expert on decoding hex.

One last bit - an excerpt from my steam "connection_log" with my steam UID replaced:

[2015-07-08 19:54:08] Log session started
[2015-07-08 19:54:08] [0,0] SetSteamID( [U:1:0] )
[2015-07-08 19:54:08] CCMInterface::OnNetworkDeviceStateChange -- Saw device up, connecting to Steam
[2015-07-08 19:54:08] [0,0] SetSteamID( [U:1:11111111] )
[2015-07-08 19:54:09] [0,0] SetSteamID( [U:1:11111111] )
[2015-07-08 19:54:09] [1,2] Connect() starting connection (eNetQOSLevelLow, 208.78.164.13:27017, UDP)
[2015-07-08 19:54:10] [1,2] ConnectionCompleted() (208.78.164.10:27019, UDP)
[2015-07-08 19:54:10] [1,2] RecvMsgClientLogOnResponse() : [U:1:11111111] 'OK'
[2015-07-08 21:40:14] [3,2] LogOff()
[2015-07-08 21:40:14] [2,2] AsyncDisconnect()
[2015-07-08 21:40:14] [2,2] ResetVoiceRecording() (was recording: 0) (last get voice time: 6366 seconds ago)
[2015-07-08 21:40:14] [2,2] Log session ended

[2015-07-08 21:40:18] Log session started
[2015-07-08 21:40:18] [0,0] SetSteamID( [U:1:0] )
[2015-07-08 21:40:18] CCMInterface::OnNetworkDeviceStateChange -- Saw device up, connecting to Steam

[2015-07-08 21:40:19] [0,0] SetSteamID( [U:1:11111111] )
[2015-07-08 21:40:20] [0,0] SetSteamID( [U:1:11111111] )
[2015-07-08 21:40:20] [1,2] Connect() starting connection (eNetQOSLevelLow, 208.78.164.14:27017, UDP)
[2015-07-08 21:40:20] [1,2] ConnectionCompleted() (208.78.164.11:27018, UDP)
[2015-07-08 21:40:20] [1,2] RecvMsgClientLogOnResponse() : [U:1:11111111] 'OK'

Any help would be greatly appreciated!

  • I'll try this tonight and see if I have a similar issue. – Adam V Jul 9 '15 at 22:23
  • @AdamV Thanks! Hoping I can get this straightened out... Perhaps the windows 10 upgrade will fix it if my OS has been corrupted in some way. – Shrout1 Jul 10 '15 at 13:08
  • Have you tried playing over a different client, like tunngle, or creating your own personal LAN lobby using something like Hamachi? At the very least this would help identify if the problem is with Steam or the installation. – B. S. Morganstein Jul 10 '15 at 16:57
  • @B. S. Morganstein I have tried a LAN game with my firewall disabled; neither myself or my friend were able to detect the hosted game. Both of us were on the same subnet, could ping one another. I will look into those other options! – Shrout1 Jul 10 '15 at 21:05
  • @B.S.Morganstein Also note that I uninstalled / reinstalled both the Steam Client and Borderlands independently :) – Shrout1 Jul 10 '15 at 23:07
1

My problem turned out to be a WES610N Ethernet Bridge sitting between my system and my router. I have no explanation for why it blocks my system from hosting or joining a game, but that is definitely the cause. It caused the same problem when I tried to host a Minecraft server. A direct connection solves it.

Crummy tech I guess! Dug through lots of documentation and couldn't figure out why the WES610n would cause issues.

  • You can click the green check mark to select this as being the final answer. – rivermont - Will B. Apr 25 '16 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.