I have created a bin folder in my home directory and put my minecraft.jar in that folder. I then used Steam's "add non-steam game" option and added the minecraft.jar, but when I click play nothing happens. I can run the .jar manually but I would like to get all my games on steam so it's all nice and organized.

2 Answers 2


This best way to enable it from steam is to create a .desktop shortcut to run the jar package. This will also allow you to provide name, description and icon to steam, as well as providing the full command line, including attributes.


I've used the following wrapper script for Minecraft back when I used to play it:

#! /bin/bash

# Minecraft launcher script

# Enable if using Oracle Java
#export LD_LIBRARY_PATH="/usr/lib/jvm/j2re1.7-oracle/lib/amd64/"

# Allow a heap size of 512M to 4096M
java -Xmx4096M -Xms512M -cp $HOME/bin/Minecraft/minecraft.jar net.minecraft.LauncherFrame

Just place it in a text file named minecraft in your bin folder, in my case I made a folder named Minecraft and put the minecraft.jar file in there to keep things clean. Please note your filesystem is case sensitive; unlike in Windows minecraft and Minecraft can coexist without causing problems.

Remember to change the permissions of the script to allow it to be executed. In the file explorer, right click and select Properties, then click the Permissions tab and check the Allow executing file as program checkbox. If you instead would prefer using the command line the command is chmod 755 ~/bin/minecraft.

The script allows for some tweaking, by default it allows Minecraft to use up to 4GB of RAM. To change this, adjust the -Xmx4096M parameter; for example 8GB will be -Xmx8192M.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .