4

I am running Origin with "disabled desktop composition", it allows me to see second monitor when I play Battlefield 4 (I can't set this option on x64 executable). But when Origin starts it shows popup:

Origin Compatibility Mode Pop0Up

How can I disable the pop-up without disabling compatibility mode?

UPDATE: Another reason to have compatibility mode: When I play Battlefield 4 after 5-10 minutes of starting game, windows show "Not enough resources - disable themes" popup. But it not remembers choice in this dialogues because BF4 has x64 executable file. I disable desktop composition in advance, so this dialog is not appearing during game.

  • You tried switching off compatablility mode? – Skye Jul 10 '15 at 20:22
  • I explained in question why I need compatibility mode. Of course this dialog is not shown with disabled compatibility mode. – Ivan Solntsev Jul 11 '15 at 9:29
  • So, what's your question? – Skye Jul 12 '15 at 22:40
  • My question: is there any way to skip this message, while leaving Origin in compatibility mode? – Ivan Solntsev Jul 13 '15 at 8:38
  • 1
    You can't disable that but why dont you play battlefield in borderless window(which is nearly equal to fullscreen)? that would allow you to see the 2nd monitor too – Nitro.de Jul 13 '15 at 8:53
1

Right click on the origin icon, click propertie, and go to compatibility. Make sure nothing is checked. That should fix it.

  • This is not what I was asking for: I want Origin to remain in compatibility mode but get rid of warning popup. – Ivan Solntsev May 21 '16 at 13:12
1

Use RegEdit to navigate to:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

in Windows Explorer and Right-Click -> Delete anything to do with Origin.

  • It would add value to your answer if you explained why the files at this path needed to be deleted. – JAL Aug 31 '16 at 21:33
  • In this question I enabled compatibility mode myself. I don't need to disable it. – Ivan Solntsev Sep 1 '16 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.