4

I have command and conquer 3 from Origin, but when I try to start it, I get the 'exception in exception handler' error and the game exits.

I've tried the Origin launcher fix as well as -runver to make the game run a different version (although this just says that it can't find any version). I run Windows 10 (I know, experimental) but this game worked at one point, and then stopped working suddenly - there wasn't even an update in between.

I suspect that it's got to do with Origin, but any help would be appreciated.

  • 3
    It's perfect how people downvote but don't provide feedback at all, like why they downvoted? – user2544765 Jul 12 '15 at 13:43
  • 1
    I don't think we can really help you out with Windows 10, Its being updated frequnently, and still has a lot of bugs, as you stated, expermiemental. – Joseph Stalin Jul 12 '15 at 14:29
  • @JosephStalin I don't think it's with 10, it might be with one of the things the game uses like vc or dxd but it doesn't make sense that it would be a problem with 10 – user2544765 Jul 12 '15 at 14:50
  • 1
    Unlike the normal patched game, the Origin version doesn't contain any older versions, by the way. It's actually a serious issue all by itself, since the balance patches done for multiplay seriously mess up the single player campaign (despite pre-release promises to completely separate the MP and SP balance). Not to mention, that old version preservation was done for mod compatibility, so mods targeting pre-1.09 versions plain don't work on the Origin version. – Nyerguds Oct 13 '16 at 7:52
1

Apparently this is an issue with recent Intel HD graphics drivers. The only solution that has been found so far is to downgrade the drivers to a version from around/before June 2014. There's a large research thread about it on answers.ea.com, here:

http://answers.ea.com/t5/C-C-The-Ultimate-Collection/-/td-p/4460184

I heard of some people who actually had an NVidia card but still had this problem, because they also had Intel HD integrated on their motherboard, and the system was simply not using the NVidia card. From what I've seen, in this case the issue is simple to resolve; you just have to make sure your computer doesn't use the integrated card. There are many guides for that online, so I'm not going to explain that here.

| improve this answer | |
  • Hmm, peculiar... this question is from 2012, though. – Nyerguds Jan 12 '16 at 12:21
  • 1
    Well, it was actually from '15, but Windows 10 broke a lot of games since then on my laptop, I believe it has something to do with a driver or DXD or something, though. – user2544765 Oct 12 '16 at 14:50
  • 1
    Hah, I somehow mixed up the day and year in "Jul 12 '15". Anyway... there's a gigantic research thread about this on answers.ea.com, so yeah, I'm pretty sure it's those Intel HD drivers;.it's not a win10-specific issue. I'm adding the link into my answer. – Nyerguds Oct 13 '16 at 7:43
  • Note that the thread was marked as "solved" at some point, but the issue actually reappeared in later intel HD driver updates. – Nyerguds Oct 13 '16 at 7:51
  • 1
    Accepting for the added link and comments,. – user2544765 Oct 14 '16 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.