0

Unlike everyone elses problems! Mine crashes after I've logged on; at the part that says: "Mojang".

I had mods installed but have since removed them completely and it still isn't working.

Below I've attached the minecraft crash report:

---- Minecraft Crash Report ----
// My bad.

Time: 7/20/15 9:27 PM
Description: Initializing game

java.lang.OutOfMemoryError: Java heap space
    at bmi.a(SourceFile:230)
    at bmh.b(SourceFile:130)
    at bmh.a(SourceFile:77)
    at bot.j(SourceFile:553)
    at bot.a(SourceFile:139)
    at bou.a(SourceFile:23)
    at bnn.a(SourceFile:99)
    at ave.am(SourceFile:448)
    at ave.a(SourceFile:310)
    at net.minecraft.client.main.Main.main(SourceFile:124)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
    at bmi.a(SourceFile:230)
    at bmh.b(SourceFile:130)
    at bmh.a(SourceFile:77)
    at bot.j(SourceFile:553)
    at bot.a(SourceFile:139)
    at bou.a(SourceFile:23)
    at bnn.a(SourceFile:99)
    at ave.am(SourceFile:448)

-- Initialization --
Details:
Stacktrace:
    at ave.a(SourceFile:310)
    at net.minecraft.client.main.Main.main(SourceFile:124)

-- System Details --
Details:
    Minecraft Version: 1.8.7
    Operating System: Mac OS X (x86_64) version 10.9.5
    CPU: 2x Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz
    Java Version: 1.6.0_65, Apple Inc.
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Apple Inc.
    Memory: 282712 bytes (0 MB) / 1060372480 bytes (1011 MB) up to 1060372480 bytes (1011 MB)
    JVM Flags: 5 total; -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    Launched Version: 1.8.7
    LWJGL: 2.9.2
    OpenGL: NVIDIA GeForce 320M OpenGL Engine GL version 2.1 NVIDIA-8.24.16 310.90.9.05f01, NVIDIA Corporation
    GL Caps: Using GL 1.3 multitexturing.
Using GL 1.3 texture combiners.
Using framebuffer objects because ARB_framebuffer_object is supported and separate blending is supported.
Shaders are available because OpenGL 2.1 is supported.
VBOs are available because OpenGL 1.5 is supported.

    Using VBOs: Yes
    Is Modded: Probably not. Jar signature remains and client brand is untouched.
    Type: Client (map_client.txt)
    Resource Packs: [PureBDcraft 512x MC18, herobrinepack9110877]
    Current Language: English (US)
    Profiler Position: N/A (disabled)

And this is the text Mojang/Minecraft shows me all the time!

Uhoh, it looks like the game has crashed! Sorry for the inconvenience.

With magic and love (?) we've managed to grab some details about the crash and >we will get on it as soon as we can You can see the full crash below

Can anyone here help me? It would mean the world to me!

7
  • 3
    You're getting an OutOfMemory exception. You've only got..a gig? of RAM. Am I reading that right? That's an incredibly tiny amount to run Minecraft and everything else on. How old is your computer? – Frank Jul 20 '15 at 21:59
  • Have you tried reinstalling it or configuring the amount of RAM your Minecraft has access to? You can modify the RAM-config in the profile settings (the settibgs of the individual launch profiles accessible throu the launcher) – BlueWizard Jul 20 '15 at 22:41
  • What a coincidence! On my in-game debug screen I have 1011 MB,too. – John Jul 21 '15 at 10:05
  • Er, @Frank ,the computer is not old. No "old" computers use <1MB RAM. It says 282712 b / 1060372480 b out of 1060372480 b,so it actually is used/allocated out of total. Minecraft has 1011 MB allowed on his/her computer. – John Jul 21 '15 at 10:11
  • Regardless of the memory issue, I suggest updating your Java. Java 6 is very old. – MrLemon Jul 21 '15 at 11:46
3

Try to increase your RAM. If you don't want to do that, you can try to allocate more RAM through the Minecraft Launcher. How to do that:

  1. Go into Profile Editor.
  2. In "Java Settings (Advanced)", check JVM arguments.
  3. In the entry-box, look for -Xmx1G and replace it with -Xmx[amount of ram goes here] in JVM arguments

The amount of RAM you put in depends on how much you have. If you want to put in 2 gigabytes, type -Xmx2G. If you want to put in 500 Megabytes, type -Xmx500M. Make sure not to put all your RAM into Minecraft.

2
  • I think it's not about RAM. It says 282712 b / 1060372480 b out of 1060372480 b,so it is used/allocated out of total. The game does not initializies well enough,so it uses a bit of RAM. – John Jul 21 '15 at 10:03
  • If you cannot increase your RAM to more than 1G, remove the 512x Sphax Pack and download something that makes more sense for your computer from their website (32 or 64). 512x textures are 1000 times bigger than the default textures. – MrLemon Jul 21 '15 at 11:54
1

Try upgrading your Java to a newer version, because the crash report indicates an older version. (Possibly an error for the indication, because it is possible to misindicate Java 8 as Java 1.40)

0

Go to Options > Video Settings. Make sure both VBOs and VSync are turned on. I see from your crash report VBOs are on, but VSync isn't there. I assume you don't have it on.

Not the answer you're looking for? Browse other questions tagged or ask your own question.