1

Since I have installed quite a few of mods I decided to also install Not Enough Items so that I wouldn't have to look at the wiki of every mod when I want to craft something.

But my NEI doesn't show an options button when I press E. I only want to play on Survival mode, so all I need is recipe mode but it's locked on cheat mode. How can I fix this?

  • You may want to try Too Many Items, as this has worked better for me than NEI, TMI uses an easier interface. – Friccadillies Sep 29 '15 at 23:55
1

The Problem

You are in a scenario where you set the mode on other mode that cheat mode but you can't change it.

Solution

Try to click the button on the bottom left. If you click it, it will change the mode into the world mode. Now just go to the option to change cheat mode and recipe mode. You'll notice a W button in front of the mode selection. Now, click it so it disappears. There you go! Recipe mode!

What is World Mode?

To simply explains it, NEI can save your own setting in each world. Lots of people are getting this trouble too. So I suggest you to check that.

  • I don't think you read my question right, when I press E it doesn't show the options* button on the bottom left corner, there is nothing there, I've seen so many videos that say how to change to recipe mode, and every single one of them says to go to options mines simply doesn't show an **options button at all, I tried reinstalling NEI and and also reinstalling **minecraft but no change. – cesar flores Jul 25 '15 at 3:27
  • Try to toggling NEI on or off using the O button. But if still no, I think you need to edit NEI in your config folder. – Christopher Angelo Jul 25 '15 at 3:35
0

I don't know what might cause the options button to not be visible... but if you do need only the recipe mode than it might be even better this way (less clutter on the inventory screen), and there is a solution.

Go to your minecraft\config\NEI folder, and open client.cfg in a text editor (like Notepad++, though anything will probably work). Therein find the line:

cheatmode=2

The number indicates mode you're in. 2 is cheatmode, 0 is recipe mode. Change it to 0, and you should achieve what you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.