I have had this problem for several days so far. I cannot log into my Mojang account. I know to log in with my email address and I know for a fact my password is correct. I have even changed it multiple times. I have also tried my brother's account and that doesn't work either. I have also tested this on three different computers. The weird part is. It only doesn't work on my home network. I brought my laptop to a friend's house and was able to log in to both accounts successfully. I have tried logging in through the launcher as well as Mojang.com and Minecraft.net. I am almost positive it has to do with the internet connection at my house. I have tried updating the router but I have yet to reset it. Does anyone have any suggestions on fixing this problem?

  • 1
    Youve already asked this question. – user106385 Jul 26 '15 at 1:51
  • @Timelord64 This is my first post. I haven't found any other post about this specifically. Would you mind linking it to me? – Zach Cartnick Jul 26 '15 at 1:54
  • Earlier this week, I commented on a different new user who has had problems logging into minecraft because their password was incorrect. Their environment was almost identical. Regardless, your problem is "I cant log into Mojang through my computer". It was the same issue this user had. The question was closed, due to being an issue directly with Mojang – user106385 Jul 26 '15 at 1:56
  • I'm going to flag this as a duplicate of a seperate question. I have managed to find a differant duplicate that does actually have an answer (or atleast, as best as arqade can give) – user106385 Jul 26 '15 at 2:00
  • @Timelord64 Haha, wow. Three different computers too. I can say I'm pretty sure that wasn't me. I could be having problems remember that though as it does sound exactly like the problem I'm facing as well as the exact same scenario. Thank you for your help. The post you linked me to didn't have a solution that worked for me but did open a new door of options to work on. I will see what I can do off of that. – Zach Cartnick Jul 26 '15 at 2:05

Given the information you have given us, I think the most likely scenario is that you have a firewall/ some sort of internet blockade up. Try to remove a firewall if you have one. Is you ISP different that your friends'? That might be an issue too. Also, try your real MC username and your email for the username field.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.