2

When I start my uplay client to play some ACII and try to login with valid credentials (tested on the uplay website) I get "A Ubisoft service is unavailable at the moment.".

I've googled the message and tried every solution I could find. Even created a ticket over at uplay's support website (which is currently malfunctioning). And got a very generic response saying it's probably my firewall, my host file or my router. It goes as far as suggesting I should open up ports 80, 443, etc.

In an attempt to save someone some serious head scratching, I will share the solution (that worked for me) below.

1
  • How to stop the message: Uninstall uPlay :P
    – Robotnik
    Commented Feb 9, 2016 at 0:19

5 Answers 5

4

Turns out the message "A Ubisoft service is unavailable at the moment." is way off. In my case, it had absolutely nothing to do with a service being unavailable, connectivity was perfectly fine. The uplay client is just not getting the response it's expecting.

The reason I claim this is because I remembered I had a second account with which, to my surprise, I was able to login to the uplay client just fine. Let me refer to my accounts as "Account A" with which I couldn't login and "Account B" which magically let me login into the uplay client.

When I logged in with "Account A" on the uplay website there was an error stating "countryCode is not ISO-3166-1". I initially ignored this since the whole website is buggy and clicking "Ask me later" got me to my account page. But when I noticed I didn't get the message when logging in with "Account B", I got suspicious. For "Account A" I made the mistake of selecting the wrong country when I signed up with it, "Netherlands Antilles" when I actually live in "The Netherlands".

After contacting support, asking them to change my country (something you can't do through your account settings ...) to "The Netherlands" I was finally able to login with both Account A and B into the uplay client.

If you're wondering why I really wanted my "Account A" to work, it's because I was able to activate and play ACII with "Account B" exactly once. When I booted the next day, to play some more ACII with "Account B", I received a pleasant "This CD Key or Activation Code is already in use with another Uplay Account". Turned out the game was, somehow, activated for "Account A". So I really wanted that account to work.

2
  • 5
    Welcome to the wonderful, wonderful world of Ubisoft's Last Word Against All Those Evil Software Pirates That Steal Our Games. Commented Jul 26, 2015 at 12:50
  • @Shadur: s/Word Against/Word That Isn't Steam Against/ Commented Mar 8, 2016 at 6:05
3

I had the same issue (With the steam version of the game), with a different solution. I managed to get around it by installing the uPlay client from https://uplay.ubi.com/.

Most likely, the client that's installed by default by Steam is old and doesn't work anymore.

1

I had the same problem with Uplay for a long time, and I tried every fix I could find on various forums, so I don't know if this fix will work for you...but I'll add it here in case it helps someone who stumbles across this in the future:

In regedit, go to Computer\HKEY_Local_Machine\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client and change the following keys:

DisabledByDefault --> Change from "1" to "0"

Enabled --> Change from "0" to "1"

After making that change, I was able to log right in; I didn't even have to reboot, so you can test this immediately and switch back if it doesn't work.

As for why the TLS 1.0 client protocol was disabled on my machine...I have no clue.

1

Old question, but I wanted to share my two cents.

I figured out my "problem" was that the Uplay client was installed in a non-standard location, because I have two hard drives and decided to install the program in F:\Program Files instead of C:\Program Files(x86).

I had to uninstall it from its previous location and install it under the default location for it to work. Nice job Ubi.

0

Make sure your uplay client is updated.

I just installed a ubisoft game via steam, registered on uplay and received this message when trying to register the cd key. I was not surprised.

The thing that worked for me was to just close uplay and press the PLAY button again on steam. It did a massive update and even changed the look and feel. Different login screen this time and a different cd key dialogue box.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .