Near the end of a game of Words With Friends, the game seems to be stuck in a mode where neither player can make a move. On the main screen on both phones it indicates that it's my move, but when I go into the game board it shows my last move instead of my opponent's. The pass, recall, and swap buttons are all disabled, and I'm not allowed to resign because the game doesn't recognize that it's my move on this screen.

I've tried rebooting my phone to unstick the game (so did my opponent), and that didn't work. This is the free version of the game on Android if that helps. Has anyone else experienced this particular problem? If so, how do I get this game unstuck?

5 Answers 5


I've had this problem before too, never really looked into how to solve it, but now that I think about it.

Wiping the application data for words with friends (Settings -> Applications -> Manage Applications -> Words Free -> Clear Data), then starting the application again (requiring you to log in since you wiped the data) should refresh your game.

As I was typing the above I saw that there's a "clear cache" button below the "clear data" button. That might solve the issue too. Clearing the cache would empty what is there and force a refresh from the servers. If clearing the cache doesn't work, the the paragraph above should solve the problem.

  • I don't have a Clear Data option, but I did try clearing the cache with no luck. I'm starting to wonder if I need to uninstall the game and reinstall? :( Commented May 24, 2011 at 13:34
  • Well that's odd, almost all applications should have a clear data option. Makes it so that the program thinks that the program was just installed. Uninstalling/reinstalling is hardly ever ideal. Maybe you don't have the latest version of Words Free? A quick upgrade might help. Come to think of it, I haven't seen this error show up since the last update.
    – Sorean
    Commented May 24, 2011 at 15:12
  • I got it less than a week ago, but I'll check for updates... It just says "Installed" so there are no updates available. Commented May 24, 2011 at 15:17
  • Time to start a new game then! Seriously though, what version of the android OS are you running? Kind of odd that you don't have the clear data button.
    – Sorean
    Commented May 24, 2011 at 16:31
  • It's firmware version 2.1-update1. I checked for a newer system update and there's none available. Commented May 24, 2011 at 17:21

I had a somewhat different problem where there's an "Oops" message and that particular game disappears from the Android phone. To work around it I logged on using a PC to finish that round.

Not the greatest solution, but better than remove/reinstall.

Also....I terminated without removing the app, which also fixed my problem. This is under settings....apps....Words With Friends. May as well clear data and cache while you're there. This also took care of players' names who were numbers.

  • Interesting solution, +1
    – Robotnik
    Commented Apr 13, 2015 at 0:42

After trying everything suggested by @Sorean my game was still stuck. I ended up having to uninstall the game entirely then reinstall it. That synched the game up to its correct state.

  • I seem to remember reading that somewhere ... WWF is well-established on the iDevices, but the Android port has a long way to go IMHO. Uninstalling something to fix it shouldn't really be a necessary option (although I've seen it other places as well). Commented May 24, 2011 at 23:15
  • @Dave: Yeah, this was definitely my last resort. If this hadn't worked I probably would have just uninstalled it completely. Commented May 25, 2011 at 1:07

Login to: https://gameswithfriends.zyngawithfriends.com/account Go to "Broken Game?"
Select "Words with Friends" Click "Refresh Game(s)"


The way i did it was by going to manage apps then going to the game then clearing the cache. Then force stop. I had to do this a few times but finally it deleted it..Note: you'll have to return to the game and pull down to refresh it, that's how you would know it's gone. It will stop popping up on your ongoing game page. Then go to the bottom and check to see if it's on the finished game area. You'll have to be patient as it can get frustrating. But eventually it will clear it....ZTE max Android....Hope this helps

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .