2

I need to play a sound file (Disk 11) on my server so that everyone can hear it, but the problem I have is that the sound plays, but when the person goes too far away from where they were, it gets quieter and finally you can't hear it at all. Is there a way to play a sound globally so that everyone can hear it and when they move they still hear it fine. Here is what I have tried:

/playsound records.11 @a

Plays for everybody but still gets quieter as you move away!

/playsound records.11 @a [High Wolume]

Blasts your ears at the beginning!

/playsound records.11

Doesn't work, requires a player

I guess what I am asking is how to play the sound server-wide so you can hear it continuously until the end?

1
  • You could use it with /execute @a, but that might not solve the problem. – The_Basset_Hound Jul 31 '15 at 23:38
6

/playsound has a volume and a minimumVolume optional argument:

/playsound <sound> <player> [x] [y] [z] [volume] [pitch] [minimumVolume] 

If you set the minimumVolume to something other than 0, players will be able to hear it at that volume outside of the sound's normal audible range.

For example:

/playsound records.11 @a 0 0 0 1 1 1

It should also be noted that a volume larger than 1 doesn't actually make the sound louder, it just makes it able to be heard from further away.

3
  • Thank you, the minimum volume thing didn't seem to work, but setting the max higher let me go far away and still hear it! Thanks! I will accept as soon as I can – Nick Jul 31 '15 at 14:23
  • @Nick The minimumVolume argument doesn't work exactly like most people would expect it to at first. It only applies to people outside of the sound's normal audible range. If you're 13 blocks away from the sound when it is played (still within where you'd normally hear it), then you might hear the sound quieter than the minimumVolume, but if you're 50 blocks away from the sound when it is played, then you'll hear it at minimumVolume. – SirBenet Jul 31 '15 at 14:33
  • Oh, I see... Yeah, that wouldn't work, because some people would start off in range but then leave the range. The Max thing worked well though... Thanks again! – Nick Jul 31 '15 at 14:56
2

You could try /execute @a ~ ~ ~ playsound records.11 @p.

What this does is execute /playsound records.11 @p for every player, and plays the sound to them.

2
  • Hey awes0meGuy360 - would you mind explaining a little about how this command works? It would make your answer that much better :) – Robotnik Aug 3 '15 at 14:34
  • @Robotnik just explained how the command works! – awes0meGuy360 Aug 4 '15 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.