I am unable to connect to my friend's LAN server, on the Technic launcher mod pack, "Vivacity".

When he puts it up, I can't even see it in my server menu. This has also been an issue when trying to use LAN servers for other games, such as Garry's Mod. When I enter the port number and try to direct connect, it says "java.net.SocketException:Network is unreachable:no further information".

I tried using our public IP as the port, in an attempt to add it to my server list, but it says "java.net.SocketException: Connection refused: no further information"

What am I doing wrong?

  • 1
    What does using your public IP as the port mean? A port is completely different than an IP
    – APCoding
    Aug 3, 2015 at 0:31
  • Try portforwarding,
    – Aequitas
    Aug 3, 2015 at 3:34
  • But I think AP Coding is on the right track, since you don't seem to understand the difference between IP and port you're probably putting in the wrong address
    – Aequitas
    Aug 3, 2015 at 3:36

2 Answers 2


A few things:

  1. Did you friend publish the world to LAN? He can do that via the /publish command
  2. Don't connect through the server list. Just go into your Multiplayer tab and scroll down. You should see his world there.
  3. Do you have different mods? Make sure your mods that you have currently installed are the exact same.
  4. Make sure that you are playing on the same version.

Point 1 and 2 are the most important. Also, as a side note, don't use an IP as a port. They are completely different.


I had this error before when trying to play with my friend. Try this method:

Assuming that you have a computer running Windows:

1: Press Windows Key + R to open the run dialogue

2: Type in "cmd" to open up the command prompt

3: In the cmd, type "ipconfig"

4: This should bring up a list of addresses. The address you want is the IPv4 address

5: Lastly, open up Minecraft and try connecting using your IPv4 address

If you are running on a Mac:

1: Click on the Apple Logo at the top left corner

2: Go to System Preferences

3: Under System Preferences, click on Network

4: At the right, it should say the status, and under that, an address in the format of 192.168.X.XXX

5: Open up Minecraft and try connecting using that address

Sorry for the information overhaul, but this did work for me.

Not the answer you're looking for? Browse other questions tagged .